Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.


CNA on windows 2008 TS as RemoteApp

Has anyone tried running cisco Network Assistant on a Windows 2008 Terminal Server as Remote-application?

When running in a normal RDP session everything works fine.

when running as RemoteApp i get messagebox :

title: "Prelaunch message dialog"

text : "unable to find the required startup resources"


Re: CNA on windows 2008 TS as RemoteApp


Re: CNA on windows 2008 TS as RemoteApp

thank you for your response.

but I see no section regarding my question in this release notes.

looking for "remote", "RDP" or "terminal server"


i see don't see W2K8 in the supported OS's.

but I see W2K3 SP1 and Windows Vista from wich W2K8 is a further development.

It DOES work on W2K8 in a normal RDP session.

maybe the paragraph about 64-bit gives a pointer in the right direction.

"You will need write permission to your home directory and to the Network Assistant installation directory so Network Assistant can create the necessary log files and preference files"

this may behave different between RDP or RemoteApp (my client is in a different tree then the Remote-App server).

New Member

CNA on windows 2008 TS as RemoteApp

Yes i have tried running CNA on windows 2008 TS as REMOTEAPP

The solution:

from the TS REMOTEAPP server do the following

copy setpaths.cmd from "c:\windows\application compability scrips" to  the same directory where the executable file from

CNA resides(prelaunch dir.). then add a few lines to setpaths.cmd

under the line :DONE

cd "d:\Program Files (x86)\Cisco Systems\Cisco Network Assistant"

"d:\Program Files (x86)\Cisco Systems\Cisco Network Assistant\utilities\prelaunch\prelaunch.exe"

At last, point the remoteapp to setpaths.cmd


Re: CNA on windows 2008 TS as RemoteApp

Hello Claus,

Glad to hear someone found some solution to this.

And that you found my post to add the comment.

My function has changed also CNA is less frequently used in our environment.

So I'm not sure wether I can try this out.

If so I'll report back.