Cisco Support Community
Community Member

CNS NetFlow Collection Engine

please advise what is it i'm missing regarding implementing CNS Netflow collection engine.

I've installed Netflow Collection engine 5.0.2 on Redhat ES 3. Installation went fine without error and web GUI is working.

I've configured one test router for exporting the netflow to the collection engine server. From the router, show ip cache flow is already showing the netflow statistics. however looking on the Netflow collection engine GUI status, there is no traffic coming in.... The router can ping the netflow collector and also there is no firewall in between.

Note: attached here is the nfc.log where there are some errors, the rest of the log files are all OK. (please let me know if some needs the Netflow collector show-tech.log)

Many thanks


Re: CNS NetFlow Collection Engine

Is the router actually exporting NetFlow?

ip flow-export source Loopback0

ip flow-export version [version number]

ip flow-export destination [NFC ip addr] [port number]

Looks like there's no /opt/CSCOnfc/Data on the NFC either.

Community Member

Re: CNS NetFlow Collection Engine

The router is already exporting flow traffic. I tried the fdget utility and can see incoming traffic being exported from the router.

I also tried exporting it to a different server running a non Cisco netflow analyzer and everything is working fine. (I however would like the Cisco NFC to work before i try a different product..)

Does anyone know why it is giving the error below.

[2005-10-19 11:38:02 BST] WARN - error in disk usage query: df: `/opt/CSCOnfc/Data': No such file or directory

[2005-10-19 11:39:49 BST] ERROR - the disk usage monitor script for /opt/CSCOnfc/Data exited unexpectedly

[2005-10-19 11:39:49 BST] FATAL - I/O error reading packet: Interrupted system call, exiting.

the folder "/opt/CSCOnfc/Data" is there however, no files are getting created.


CreatePlease to create content