Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Config Fetch Fails

I have been getting the following error when I archive my configs: CM0151 VLAN RUNNING Config fetch failed. The configuraiton file is backed up fine, its just the vlan.dat file that does not work. my transport protocols are Telnet, then TFTP. I am using RME 4.1.1

15 REPLIES
Cisco Employee

Re: Config Fetch Fails

What type of device is this? Does it have a vlan.dat on flash?

New Member

Re: Config Fetch Fails

Thats the thing. Those switches do not have a vlan.dat file, because there is no vlans configured on those devices.

Cisco Employee

Re: Config Fetch Fails

Then this is my bug, CSCsq66458. If you contact TAC, you can get a patch for RME 4.1.1.

New Member

Re: Config Fetch Fails

I opened a TAC case on this for them to send me the patch. Thanks.

New Member

Re: Config Fetch Fails

I am having the same problem...I am running RME 4.2.0.

Is there still a bug?

New Member

Re: Config Fetch Fails

To fix this you have to copy a vlan.dat file from a switch that has one on the flash. Then TFTP that vlan.dat file to the switches that do not have one. That is what fixed my problem.

New Member

Re: Config Fetch Fails

Thanks. Are you talking about a default vlan.dat file?

New Member

Re: Config Fetch Fails

yes

New Member

Re: Config Fetch Fails

Did you get instructions from TAC on how to do this?

New Member

Re: Config Fetch Fails

Its just mainly tftp a vlan.dat file from another switch, then tftp that file to the switches that do not have one. They do not have a patch out for this yet, so this is a work around.

New Member

Re: Config Fetch Fails

OK, Thanks. I am assuming by your response that ANY vlan.dat file will do? I want to make sure before I do this. I do not want to 'break' anything when I do this. Thanks again.

New Member

Re: Config Fetch Fails

I found another work around. Simply create a VLAN and ust keep it shutdown. I used VLAN 2 and issed the shutdown command, resync'd the archive and voila.

Cisco Employee

Re: Config Fetch Fails

The patch is certainly available, and has been given out to a number of customers. However, it is now out of date. If you have a newer version of the SharedDcmaCatIOS package, my patch will overwrite it, and could break other things. Therefore, the workaround is recommended now until LMS 3.2 comes out this summer.

Bronze

Re: Config Fetch Fails

The creation of a vlan and a name worked for me too.

vlan 2

name TEST

and it created a VLAN.dat file in flash.

New Member

Re: Config Fetch Fails

I had this problem, too. I had about 250 devices Partially Collected because CW could not download the vlan.dat.

I just started a netconfig job for those devices.

The job ran the following command:

vlan database

vlan 666 name CiscoBug

exit

vlan database

no vlan 666

exit

Works fine for me =). The vlan.dat keeps on flash even if u delete the just created vlan with the "no" command.

Patrick

232
Views
0
Helpful
15
Replies
CreatePlease to create content