Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

CUSSM connecting to agents for CUOM & CUSM

I installed CUSSM on an existing CUOM/CUSM installation.

Installation seemed to go fine... for what it is worth, no errors were reported.

I soon realized it will not work unless I tell the application on how to connect to the CUOM and the CUSM.

But no questions were asked during install so I clicked about a bit in the GUI.

Easy, click "discover", enter 127.0.0.1 and it should discover....? Right?

Nope it doesn't discover anything. netstat sees the port 12140 listening

I tried to add 127.0.0.1 and also the regular IP address and the hostname. No joy.

In the docs the some config files are mentioned

I modified pronet.conf like this:


pronet.ssm.omagents.number=3                                                                                                                  
                                                                                                                                              
                                                                                                                                               
                                                                                                                                              
#Make the following entries for as many number of agents specified above,start number with 1 and increment by 1 for each additional agent     
                                                                                                                                              
#pronet.ssm.omagent.<number>.port - Refers to the port the installed agent is listening on                                                    
                                                                                                                                              
#pronet.ssm.omagent.<number>.monitors - Refers to the monitors that have to be autocreated on these agents,multiple values are comma separated.
                                                                                                                                              
#Example :                                                                                                                                    
                                                                                                                                              
pronet.ssm.omagent.1.port=12124                                                                                                               
                                                                                                                                              
pronet.ssm.omagent.1.monitors=10.170.101.123                                                                                                 

This helped in the sense that now it "Sees" the CUOM on adress 127.0.0.1   ??? yeah.

The whole thing however remains a mistery however:

What needs to done to gt it to work?

Do we need an agent per module? If so, should we then install the agent twice?

What addresses and ports should be used?

How do get the CUSSM to "discover" these addresses and ports? Or what config file and parameter holds this info ?


Does it use the admin username/pasword just for discovery or will it fail if this ever changes?

When clicking discover it now shows this:

                          The IP Address of Operations Manager (OM) is 127.0.0.1                                                                                 
                          SSM Agent on OM IP Address : 127.0.0.1, listening on port : 12124 is active.                         
                          Started to import data from OM ...                                                                   
                          Finished importing data from OM.                                                                     
                          Started checking monitor elements for IPSLA Tests ...                                                
                          Could not find or create monitor element(s) for SSM IPSLA Data Jitter .                              
                          Could not find or create monitor element(s) for SSM IPSLA Gatekeeper RD.                             
                          Could not find or create monitor element(s) for SSM IPSLA Ping Echo.                                 
                          Could not find or create monitor element(s) for SSM IPSLA Ping Path Echo.                            
                          Could not find or create monitor element(s) for SSM IPSLA UDP Echo.                                  
                          Finished checking monitor elements for IPSLA Tests.                                                  
                          Started checking monitor elements for GSU Data ...                                                   
                          Completed discovery of latest monitor elements for SSM System Utilization For Unified CM.            
                          Could not find or create monitor element(s) for SSM System Utilization For IPCC.                     
                          Could not find or create monitor element(s) for SSM System Utilization For Unity.                    
                          Created the monitor element(s) for SSM Unified CM Performance .                                      
                          Could not find or create monitor element(s) for SSM Unity Performance.                               
                          Could not find or create monitor element(s) for SSM Unity Connection Performance.                    
                          Completed discovery of latest monitor elements for SSM Gateway Utilization.                          
                          Completed discovery of latest monitor elements for SSM System Utilization For IOS Routers.           
                          Could not find or create monitor element(s) for SSM CUE Performance.                                 
                          Completed discovery of latest monitor elements for SSM Trunk Utilization.                            
                          Completed discovery of latest monitor elements for SSM Gatekeeper Performance.                       
                          Could not find or create monitor element(s) for SSM IPCC Performance.                                
                          Could not find or create monitor element(s) for SSM CME Performance.                                 
                          Could not find or create monitor element(s) for SSM System Utilization For Unity Connection.         
                          Finished checking monitor elements for GSU Data.                                                     
                          The IP Address of the Service Monitors (SM) configured are :                                         
                          [eubebrusvcuom]                                                                                      
                          Started to add the SSM Agent on SM IP Address : eubebrusvcuom ,listening on port : 12124 to SSM server
                          Agent failed to get added to SSM Server. Please check log files for additional details.              
                          SSM Agent is not active on IP Address : eubebrusvcuom ; Port : 12124,                                
                          Possible reasons could be the Agent is disconnected or is already connected to another server        
                          Monitor element(s) for this agent can not be discovered at this time, please try later.              
                          SSM Agent is not active on IP Address : 10.170.101.123 ; Port : 12124,                               
                          Possible reasons could be the Agent is disconnected or is already connected to another server        
                          Monitor element(s) for this agent can not be discovered at this time, please try later.

Did anyone get this to work?

What document did I miss that explains this?

Cheers,

Michel

9 REPLIES
Cisco Employee

Re: CUSSM connecting to agents for CUOM & CUSM

Michel,

It appears you able to connect to OM succesfully.  "Created the monitor element(s) for SSM Unified CM Performance . "

Go to SSM > Custom Graphs > Monitor Types

What and how many monitor types you able to discover from OM and SM?

Re: CUSSM connecting to agents for CUOM & CUSM

Thanks for your response jaso,

I am connected to the Operations Manager. But I had to edit the config file mentioned.

It still doesn't see the Service Monitor running on the same machine.

To see stats from both applications I assume I should add a second agent?

When all applications are on seperate servers the agent can run on the default port

When all application run on the same server they can't as they need their own listening port.

Any idea how to configure this? And of course  to get CUSSM to discover it?

Cheers,

Michel

Cisco Employee

Re: CUSSM connecting to agents for CUOM & CUSM

For SM to be discovered by SSM.  You need to add SM in OM first.

Logon to OM >  UC Management Suite tab > Service Monitor,  from here, you may add the SM server, then rediscover from SSM

If OM, SM and SSM are running on same server (coresident mode), no need to install SSM Agent separately.

If OM, SM and SSM, each running on different servers (standalone mode),  SSM Agent has to be installed in remote OM and SM servers.

No need to edit any config file in OM, SM and SSM servers.

Re: CUSSM connecting to agents for CUOM & CUSM

HI Jaso.

SM is configured in OM. They have been working fine together for quite a while.

The SSM module is new here.

So SSM should have discovered it.

In a sense it has discovered it. I didn't configure the hostname in SSM.

I did configure the hostname in OM as it kept on asking for a password everytime we went from OM to SM. (known 2.2 bug)

But SSM says it is unable to connect to the agent.

Any idea how to "troubleshoot" tis connection issue?

Cheers,

Michel

Cisco Employee

Re: CUSSM connecting to agents for CUOM & CUSM

You may review or forward logs in SSM, under  \pw\pronto\logs\

ProactiveNet.log

ProactiveNetAgent.log

ProServices.log

Re: CUSSM connecting to agents for CUOM & CUSM

Jaso,

I've decided to uninstall CUSSM, remove any trace I could stil find and reinstall as default as I can.

I also added the SM as an IP address rather as the host name.

No errors during install, every thing seem fine.

Something listens on the agent port:

C:\Documents and Settings\Administrator>netstat -a | find "12124"
  TCP    EUBEBRUSVCUOM:12124    EUBEBRUSVCUOM.eu.didata.local:0  LISTENING
  TCP    EUBEBRUSVCUOM:3501     EUBEBRUSVCUOM.eu.didata.local:12124  ESTABLISHED
  TCP    EUBEBRUSVCUOM:12124    EUBEBRUSVCUOM.eu.didata.local:3501  ESTABLISHED

I go to the configuration screen and it looks like the previous install.

So once again I tell it to discover. The response is nearly instant.

I tried the OM ip address, the hostname and 127.0.0.1

What I'm I missing here?

License is valid for another 89 days

Agent is running and listening on the default port

The same SSM credentials are used to login and start the discovery

The messages in the logs don't tell me what SSM discovery is looking for. It rather looks as if I didn't configure something.

Cheers,

Michel

After a reboot SSM has changed its mind about why the discovery is not working.

It can't get the OM license info....... clueless

Cisco Employee

Re: CUSSM connecting to agents for CUOM & CUSM

Sorry for late reply Michel. I was away.  You must have missed this step for SSM to discover CUOM:

Please refer to

http://ciscosystems.com/en/US/docs/net_mgmt/cisco_unified_service_statistics_manager/1.2/user/guide/admin.html#wpmkr1084282

Configuring Service Statistics Manager to Connect with Operations  Manager

You must perform this procedure before you run discovery for the first  time so that Service Statistics Manager obtains the necessary security  certificate from Operations Manager. If you reinstall Operations  Manager, you must also perform this procedure afterward to ensure that  Service Statistics Manager obtains an updated security certificate. If  Service Statistics Manager does not have an up-to-date security  certificate, discovery will not complete; in this case, errors indicate  license invalidity.


Note The procedure below is also included in Quick Start Guide for Cisco Unified Service  Statistics Manager (post-installation configuration steps). If you  are not sure whether the command has been run, it is OK to run it.



Step 1 Determine whether Operations Manager  uses an SSL port other than 443 (the default SSL port).

Step 2 If Operations Manager uses an SSL port  other than 443, perform these steps:

Navigate to this directory: <Installation Directory>\pw\pronto\conf

Edit the pronet.conf file and, find  this line: pronet.ssm.om.port.https=443

Replace 443 with the SSL port that  Operations Manager uses

Step 3 On your Service Statistics Manager  system, navigate to this directory: <Installation  Directory>/pw/pronto/bin and open a command prompt.

Step 4 From the command prompt, type this: ConfigureSSMToSSLOM  where:

servername is the IP address or DNS  name of the Operations Manager server.

(Optional) OMSSLport is the SSL port  that Operations Managers uses. If you do not provide a value, the  default SSL port 443 is used.

Step 5 Press Enter. Several messages are  displayed.

Step 6 Restart the Service Statistics Manager  server. From the command prompt, type:
pw sys start

Step 7 Close any existing browser sessions.

Step 8 Start your browser again and log in to  Service Statistics Manager.

Re: CUSSM connecting to agents for CUOM & CUSM

Hi jaso,

That did it. I found the procedure you mention in the troubleshooting part of the install guide but had no time to try yet.

This always needs to be done then? It is not automatic?

Thanks anyway.

Cheers,

Michel

Cisco Employee

Re: CUSSM connecting to agents for CUOM & CUSM

This procedure is just one time, on initial SSM connectivity to CUOM (for SSM to be authenticated by CUOM, for security reasons).

SSM 1.3 release has this procedure automated. User no longer to run batch file manually.

Thank you for your patience Michel.

988
Views
5
Helpful
9
Replies
CreatePlease to create content