Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CW LMS portal URL does not change aft hostname changed

Hi Experts,

I have run the change hostname.pl script in bin folder as instructed by the Common Services user guide.

However, CW LMS Portal url doesn't change according to the new hostname. Is it normal or do I left out any necessary step?

23 REPLIES
Cisco Employee

Re: CW LMS portal URL does not change aft hostname changed

Please provide a screenshot illustrating exactly what has not been changed.

New Member

Re: CW LMS portal URL does not change aft hostname changed

Hi jclarke,

The old hostname is iteserver10.

The new hostname is ciscoworkProd.

However, aft running hostnamechange.pl, the CW LMS portal url remained the old hostname upon launching.

I have attached the screen shot of the web browser when launching it.

Cisco Employee

Re: CW LMS portal URL does not change aft hostname changed

I assume you arrived at this error by clicking on the CiscoWorks desktop icon? If so, the URL pointed to by that shortcut does not change. You will need to create a new URL shortcut. To do this, right-click on the desktop, and select New > Shortcut. Enter the location for the shortcut as http://ciscoworksprod:1741/ . You can change the shortcut icon to the CiscoWorks icon by pointing the icon path to NMSROOT\MDC\etc\ciscoWorks.ico.

New Member

Re: CW LMS portal URL does not change aft hostname changed

Hi jclarke,

I have created the shortcut. But it seems like I am still not able to view the login page from the new url. Web browser still prompting "The page cannot be displayed" error.

I tried to start and stop the Daemon manager for several times but problem remained unsolved.

I have attached the running result for hostnamechange.pl script. Please advise. Thanks!

Regards

Yi Shyuan

Cisco Employee

Re: CW LMS portal URL does not change aft hostname changed

Since the URL in the browser is clearly the old hostname, how did you get to this error? If the new shortcut points to the new hostname, and ciscoworksprod is the actual COMPUTERNAME of this server, then you should get a successful connection.

Are you getting the same error when the browser is showing the URL to be http://ciscoworksprod:1741 ?

New Member

Re: CW LMS portal URL does not change aft hostname changed

yes, even with the with the new url http://ciscoworkprod:1741

Cisco Employee

Re: CW LMS portal URL does not change aft hostname changed

Please post the output of the pdshow command.

New Member

Re: CW LMS portal URL does not change aft hostname changed

Where can I get that?

Cisco Employee

Re: CW LMS portal URL does not change aft hostname changed

From a DOS prompt, run the command pdshow, and capture the output.

New Member

Re: CW LMS portal URL does not change aft hostname changed

Hi jclarke,

As requested.

Thanks!

Cisco Employee

Re: CW LMS portal URL does not change aft hostname changed

According to this, everything is running properly. You should be able to go to http://ciscoworksprod:1741/ on the server itself, and receive the login screen provided that really is the hostname of the server (i.e. in the output of the DOS command "SET" the value of COMPUTERNAME is CISCOWORKSPROD). You can also try connecting to http://IPADDR:1741 where IPADDR is the IP address of the server.

New Member

Re: CW LMS portal URL does not change aft hostname changed

I tried using http://IPADDR:1741. It gave me a blank screen immediately aft login. LMS Portal works fine when I tried to change the hostname back to the old one.

Cisco Employee

Re: CW LMS portal URL does not change aft hostname changed

If the old hostname still works, then you have not properly set the hostname on the server. Please post the output of the DOS SET command, the NMSROOT\lib\classpath\md.properties, and the NMSROOT\MDC\etc\regdaemon.xml.

New Member

Re: CW LMS portal URL does not change aft hostname changed

Hi jclarke,

As requested.

Thanks

Cisco Employee

Re: CW LMS portal URL does not change aft hostname changed

According to this, LMS thinks the hostname is still iteserver10. You need to re-run the hostnamechange.pl script:

NMSROOT\bin\perl NMSROOT\bin\hostnamechange.pl -ohost iteserver10 -nhost ciscoworkprod

You need to run this script as a local Administrator. Then you need to reboot.

New Member

Re: CW LMS portal URL does not change aft hostname changed

Hi jclarke,

Here the updated one.

Thanks and Regards

YS

Cisco Employee

Re: CW LMS portal URL does not change aft hostname changed

Good, these look fine. If you reboot, you should be able to access LMS now.

New Member

Re: CW LMS portal URL does not change aft hostname changed

Hi jclarke,

Are you saying to reboot the server after running hostnamechange.pl script?

Regards

Yi Shyuan

Cisco Employee

Re: CW LMS portal URL does not change aft hostname changed

Yes.

New Member

Re: CW LMS portal URL does not change aft hostname changed

Hi jclarke,

I got a blank page upon login to CW LMS portal. Please refer to the screen shot.

Thanks and Regards,

YS

Cisco Employee

Re: CW LMS portal URL does not change aft hostname changed

Please post the NMSROOT\MDC\tomcat\logs\stdout.log.

New Member

Re: CW LMS portal URL does not change aft hostname changed

Hi jclarke,

As requested.

Regards

YS

Cisco Employee

Re: CW LMS portal URL does not change aft hostname changed

According to this, everything is fine. Try accessing LMS from an external client. If you're using IE, make sure the LMS server is in your list of Trusted Sites.

259
Views
0
Helpful
23
Replies