Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
Blue

CWA engine may not be running

Made a random click into CiscoWorks Assistant -> Workflows -> Server Setup (http://hostname:1741/cwa/serverSetup.do), but received the following error, after eons of "Collecting existing server information. Please wait....":

CWA025: Could not launch the workflow.

CWA engine may not be running.

Restart the daemon manager of the server:On Windows: 1. Enter net stop crmdmgtd 2. Enter net start crmdmgtd On Solaris: 1. Enter /etc/init.d/dmgtd stop 2. Enter /etc/init.d/dmgtd start If the problem persists, contact the CiscoWorks server administrator.

I don't see any proc resembling CWA engine in pdshow:

******* ***** ***

RMEDbEngine Program started - No mgt msgs received 11776

ANIDbEngine Program started - No mgt msgs received 11786

WlseUHIC Running normally 11806

CmfDbEngine Program started - No mgt msgs received 11807

CmfDbMonitor Running normally 11817

ESS Program started - No mgt msgs received 11818

MACUHIC Running normally 11820

UTLITE Running normally 11821

EssMonitor Running normally 11822

EventFramework Program started - No mgt msgs received 11823

SyslogCollector Program started - No mgt msgs received 11824

IpmDbEngine Program started - No mgt msgs received 11825

ProcSysBus Program started - No mgt msgs received 11835

OpsxmlDbEngine Program started - No mgt msgs received 11836

OpsXMLRuntime Administrator has shut down this server 0

CSDiscovery Never started 0

CSRegistryServer Running normally 11847

Tomcat Program started - No mgt msgs received 11848

TomcatMonitor Running normally 11873

Apache Running normally 11904

DCRServer Running normally 11905

CMFOGSServer Program started - No mgt msgs received 11947

CampusOGSServer Program started - No mgt msgs received 11951

EssentialsDM Running normally 11952

RMEOGSServer Program started - No mgt msgs received 11960

ICServer Running normally 11961

ConfigMgmtServer Program started - No mgt msgs received 11962

UTManager Running normally 11963

LicenseServer Program started - No mgt msgs received 11964

FDRewinder Never started 0

NameServer Program started - No mgt msgs received 11965

NameServiceMonitor Running normally 11991

EDS Running normally 11992

ANIServer Running with busy flag set 11997

UTMajorAcquisition Never started 0

EDS-GCF Running normally 12000

jrm Running normally 12001

CTMJrmServer Running normally 12002

ChangeAudit Program started - No mgt msgs received 12010

SyslogAnalyzer Program started - No mgt msgs received 12011

IPMProcess Program started - No mgt msgs received 12012

IPMOGSServer Program started - No mgt msgs received 12024

diskWatcher Running normally 12025

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: CWA engine may not be running

That's your problem. This file must exist, and have:

-rwxr-x--- 1 casuser casusers

If this file doesn't exist, it points to a bad installation, or post-installation corruption. You may be able to regenerate the Config.pol file by running dbpasswd.pl on the opsxml dsn. However, the /etc/opsxml/curl subdirectory will not be recreated. It would be better to reinstall CWA.

9 REPLIES
Blue

Re: CWA engine may not be running

I see OpsXMLRuntime is not running. CWA.log is full of:

11/Nov/2008 14:05:13:953 INFO com.cisco.cwa.log.CWALog print - DB Connection s

uccessful

11/Nov/2008 14:05:13:968 INFO com.cisco.cwa.log.CWALog print - Database client

object is null!

11/Nov/2008 14:05:13:977 INFO com.cisco.cwa.log.CWALog print - Result of query

: SELECT RunningStatus FROM CWA_WFSession WHERE WFID=4 AND CurWFStepID=1 is:

sXML Status="Success">

11/Nov/2008 14:11:54:040 ERROR com.cisco.cwa.log.CWALog print - WFBackend: fail

ed to get details data

11/Nov/2008 14:11:54:042 ERROR com.cisco.cwa.log.CWALog print - SI could not ge

t data from opsxml

11/Nov/2008 14:11:54:108 INFO com.cisco.cwa.log.CWALog print - Result of query

: Select * from CWA_ResourceTable WHERE CWA_ResourceTable.ResourceID = '025' is

:

25

English

Could not launch the workflow.

1

CWA engine may not be running.

Restart the daemon manager of the server:

On Windows:

1. Enter net stop crmdmgtd

2. Enter net start crmdmgtd

On Solaris:

1. Enter /etc/init.d/dmgtd stop

2. Enter /etc/init.d/dmgtd start

Cisco Employee

Re: CWA engine may not be running

What version of LMS is this? If this is Solaris, post the daemons.log. If this is Windows, post the OpsXMLRuntime.log. In both cases, post the NMSROOT/objects/wfengine/program/OpsXML.log.

Blue

Re: CWA engine may not be running

LMS 3.1 on Sol 10.

less /opt/CSCOpx/objects/wfengine/program/OpsXML.log

OpsXML Server Starting at Wed Oct 22 13:30:07 2008

OpsXML Server shutdown at Wed Oct 22 13:33:04 2008

Blue

Re: CWA engine may not be running

daemons.log

Cisco Employee

Re: CWA engine may not be running

Please post the /opt/CSCOpx/objects/wfengine/program/logs/PolicyServer.log.

Blue

Re: CWA engine may not be running

less /opt/CSCOpx/objects/wfengine/program/logs/PolicyServer.log

Starting Ops XML ...

Starting OpsXML Runtime

Version 3.4.0.3

Loading default Intent

Error reading file:/etc/opsxml/Config.pol

Provisioneer Main Bus is out of service

Wait Helper exited

Wait Helper exited

Cisco Employee

Re: CWA engine may not be running

That's your problem. This file must exist, and have:

-rwxr-x--- 1 casuser casusers

If this file doesn't exist, it points to a bad installation, or post-installation corruption. You may be able to regenerate the Config.pol file by running dbpasswd.pl on the opsxml dsn. However, the /etc/opsxml/curl subdirectory will not be recreated. It would be better to reinstall CWA.

Blue

Re: CWA engine may not be running

Thanks, I find it's a perms problem because I had to change the UID/GID numbers of casuser/casuseers post-install, which Sol 10 no longer updates the files to reflect, unlike Sol 8. Are there any other places LMS drops files into, other than these three: /opt/CSCOpx, /var/adm/CSCOpx, and /etc?

ls -al /etc/opsxml

total 32

drwxr-x--- 3 830071 9999992 512 Oct 22 13:29 .

drwxr-xr-x 60 root sys 4608 Nov 11 06:46 ..

-rwxr-x--- 1 830071 9999992 8472 Oct 22 13:35 Config.pol

drwxr-xr-x 2 830071 9999992 512 Oct 22 13:29 curl

Cisco Employee

Re: CWA engine may not be running

No other places where files would be owned by casuser.

348
Views
5
Helpful
9
Replies
CreatePlease to create content