Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

CWSI folder & ANIServer.properties Missing - HELP!

I had to reboot our server yesterday and then could not open topology services in CM, it says ANIServer is not started as well as WlseUHIC. I looked in the ANIServer.log file and I see this repeatedly:

MESSAGE AniMain: Properties will be read from C:\PROGRA~1\CSCOpx\campus\etc\cwsi\ANIServer.properties

Failed to open properties file: C:\PROGRA~1\CSCOpx\campus\etc\cwsi\ANIServer.properties

I navigated to C:\PROGRA~1\CSCOpx\campus\etc and the only directory there is "users", I do not see a CWSI folder and thus no ANIServer.properties file. Could this have gotten wiped out somehow?? Im stumped, tried restarting daemons, etc and also tried starting ANIServer from inside CW process management - no luck. I have a backup from 1/13, would a restore fix this?? Any help is greatly appreciated!

1 REPLY
Cisco Employee

Re: CWSI folder & ANIServer.properties Missing - HELP!

This is very bad. I've never seen this directory deleted. If you have a backup, you can restore that backup, but some files will still be missing (as they are installed as part of the application). Your best bet is to reinstall and repatch Campus Manager, then restore your backup to restore your settings.

262
Views
5
Helpful
1
Replies
CreatePlease to create content