Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Device Discovery Issue

This is a bit strange and I am hoping that someone has seen this before. The Device Discovery in our LMS install has stopped working. The discovery.log file output is below..

2007/08/31 10:55:24 main MESSAGE DiscoveryMain: Properties will be read from D:\PROGRA~1\CSCOpx\campus\etc\cwsi\DiscoveryStatus.properties

2007/08/31 10:55:24 main MESSAGE DiscoveryMain: Properties will be read from D:\PROGRA~1\CSCOpx\campus\etc\cwsi\DiscoveryStatus.properties

2007/08/31 10:55:24 main FATAL ERROR ServiceModule: undefined property: ServiceModuleList

I read a while ago about discovery stopping if there were more than 200 seed devices, but our LMS installation only has 175 seed devices.

Any ideas and all help gratefully received.

2 REPLIES
Cisco Employee

Re: Device Discovery Issue

Can you try the following:

Please go to d:\progra~1\CSCOpx\campus\etc\cwsi directory.

Do a backup of DeviceDiscovery.properties file (rename it to DeviceDiscovery.properties.bak)

Copy the DeviceDiscovery.properties.orig and rename it to DeviceDiscovery.properties in the same loation.

Add the following to the file:

DEVICESROOT=D:\\PROGRA~1\\CSCOpx\\campus\\lib\\classpath

(Please note that DEVICESROOT= may be present in the file so you may

replace that line.)

Restart the daemon manager.

Re-add the seed device and SNMP credentials.

Community Member

Re: Device Discovery Issue

Davistan - thanks for the help - stupidly enough I posted this exact same query (which you replied to then as well) in February when I had the same issue. What I had forgotten is the fact that I recently rebuilt the server and had forgot to take the above into account after the rebuild.

I found the old reply, applied the suggested fix from yourself and all is well and working.

Thansk for taking the time to help.

143
Views
10
Helpful
2
Replies
CreatePlease to create content