Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Device Discovery not working correctly

Hello,

we are running CiscoPrime LMS 4.1 and I have the following problem.

I have configured SNMP Settings as shown below (the order of the targets is exactly as it is configured on the server):

As can be seen we use three different read community strings. I also have exluded a bunch of IP ranges and IPs from the filter settings. When I manually start discovery everything works fine, meaning that all devices in the above ranges that need to be discovered are discovered as "reachable".

The problem appears in the scheduled discovery (happens once daily). In that case only the devices with Read Community snmp1, get discovered as "reachable". All other devices with Read community snmp2 & snmp3, as well as those that are excluded in the filter settings, are discovered as "unreachable".

The discovery uses DCR as seed and seed devices are also configured.

Has anyone faced this problem before?

I also have a problem with PingSweep in the discovery, but I will open another discussion so that I don't complicate this one too much.

Thanks in advance,

Katerina

1 REPLY
New Member

Device Discovery not working correctly

I have solved this issue, quite a while back, but I would like to update the post!

In Cisco Prime 4.1 you have to configure snmp values for both manual discovery (start discovery now) and for scheduled discovery (Inventory --> Device Administration --> Discovery --> Schedule --> Edit Settings).

I was missing the second part!

436
Views
5
Helpful
1
Replies
CreatePlease to create content