Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DFM 3.2.0 device discovery problem - stuck in questioned

Hi all,

I have a problem with DFM device discovery status. Two devices are added to DFM but booth of them are in Questioned state.

When I check device details its saying SNMP Timeout problem.

DFM.JPG

I increased SNMP timeout to maximum of 30 sec, but there's no changes. Can someone help me about this???

thanks in advanced

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: DFM 3.2.0 device discovery problem - stuck in questioned

12 REPLIES
New Member

Re: DFM 3.2.0 device discovery problem - stuck in questioned

can anyone help about this?

I added two more devices and both of them are stuck in questioned state.

Cisco Employee

Re: DFM 3.2.0 device discovery problem - stuck in questioned

- Go to DFM > Device Management > Rediscover/Delete. Click on your test
device and send me a screenshot of the resulting page, showing the Item
Information.

- Go to Common Services > Device and Credentials > Device Management. Select
only your test device and click Export. Send me the resulting text file from
the server (Be sure to remove any sensitive data).

- Send show version and show run from your test device (not show tech).

- \CSCOpx\log\dfmLogs\cfi\InventoryCollector.log

- \CSCOpx\log\dfmLogs\TIS\DeviceMangement.log

:.:.:.:.:.:.:.:.:.:.:.:.:.:.:.:.:.:.:.:.:.:.:.:.:

Try to discover the device using the cli:

NMSRoot/objects/smarts/bin>sm_tpmgr -s DFM --add-agent=

New Member

Re: DFM 3.2.0 device discovery problem - stuck in questioned

hi mate, thanks for your reply,

files U requested are attached here.

I tried to discover device usig CLI but same result. Devices are in Questioned status.

Thanks In advanced.

Cisco Employee

Re: DFM 3.2.0 device discovery problem - stuck in questioned

You may benifit from installing the cumulitive update. It can be found here:

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCta56151

Thanks

New Member

Re: DFM 3.2.0 device discovery problem - stuck in questioned

Thank for reply mate,

but i did' find any update on page U gave me, just info about CSCta56151 bug.

is there any update for this bug?

cheers

Cisco Employee

Re: DFM 3.2.0 device discovery problem - stuck in questioned

New Member

Re: DFM 3.2.0 device discovery problem - stuck in questioned

Thanks Nick,

I will try the suggested patch  ang get back to U with results.

patches:

dfm3.2-win-CSCta56151.tar
dfm3.2-win-CSCtb87449.tar

New Member

Re: DFM 3.2.0 device discovery problem - stuck in questioned

problem solved

New Member

DFM 3.1.3 device discovery problem

Hi Nick ,

I am using LMS 3.1 DFM 3.1.3

I have added 130 devices in DCR through CSV file,

Alls are showing in CS moduls (Device Allocation summary) but those are not come in DFM module.

I am put all modules in auto allocation mode

I have restarted services (crmdmgtd)  and also restarted hard reboot server.

I have also checked pdshow command all services are running ok.

I had tried with all database reinitialized using all those command

NMSROOT\bin\perl.exe NMSROOT\bin\dbRestoreOrig.pl dsn=cmf dmprefix=CMF

same for rmeng, ani, ipm, dfminv, dfmemp, dfmfh, opsxml, upm

but probleme is same .

I had removed both database file from NMSROOT/objects/smarts/local/repos/ISF after data base reintialized

Still I did't get devices in DFM>> Devices Management >> Device Import

some of log file and screensort of DFM are attached for ref

pls help me

New Member

Re: DFM 3.2.0 device discovery problem - stuck in questioned

Hi there, just to conclude this topic with a solution to original problem...

after applying patches:

dfm3.2-win-CSCta56151.tar
dfm3.2-win-CSCtb87449.tar

the problem was still present, but couple of devices vent to KNOWN state, and others stayed in QUESTIONED.

Only thing different on these devices ware that KNOWN devices ware added manually to DCR and other devices ware discovered using device discovery.

With help of coupe of associates we found out that only difference between this two sets of devices (manually added and discovered) is that discovered devices  have ENGINE ID field in Device Credentials automatically filled.

After deleting only Engine ID from Device Credentials and adding them again to DFM all of them vent to KNOWN state.

I'm not sure if this is caused by a bug in DFM, becouse Engine ID is added automatically in discovery process, but it's a reason that they get stuck in QUESTIONED state?

I hope this might be helpful to other LMS users.

cheers

New Member

Re: DFM 3.2.0 device discovery problem - stuck in questioned

Hello,

I am with a the same problem to configure DFM . All devices that I added stay with status QUESTIONED. I checked the credential and All is okay. About tha patches mentioned in the case I installed all but the problem not solve.

I want to know how you do to delete the Engine ID of the credential of the devices. because how you saw after this the devices change the status to Know right.

Thanks,

João Ferreira.

New Member

Re: DFM 3.2.0 device discovery problem - stuck in questioned

Hi João,

U can delete Engine ID in DEVICE AND CREDENTIALS > DEVICE MANAGEMENT > select a device and go to EDIT CREDENTIALS.

Then U Select a used Credential Set to Edit and under the SNMP CREDENTIALS u can find Engine ID field.

deleting Engine ID solved my problem, I hope it'll be the same for you.

1315
Views
0
Helpful
12
Replies