Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

DFM custom rules - syntax problem

I am trying to create a custom rule that will allow me to increase the %Utilisation threshold on specific trunk ports on a number of switches. I cannot get the syntax of the rule to be accepted can anyone help me with this? The rule I am using is copied below.

Thanks.

(TrunkPort.SystemName equals "*****-3750-01.bgs.com" AND

TrunkPort.Description equals "GigabitEthernet1/0/49" OR

TrunkPort.Description equals "GigabitEthernet2/0/49") OR

(TrunkPort.SystemName equals "#####-3750-01.bgs.com" AND

TrunkPort.Description equals "GigabitEthernet1/0/49" OR

TrunkPort.Description equals "GigabitEthernet2/0/49")

13 REPLIES
Cisco Employee

Re: DFM custom rules - syntax problem

Complex rules like this are not supported. You will not be able to mix AND and OR like this with DFM customizable groups as you cannot create child groups. You would need to modify separate groups for this.

Community Member

Re: DFM custom rules - syntax problem

Should the following syntax work?

TrunkPort.SystemName equals "*****-3750-01.bgs.com" AND

TrunkPort.Description equals "GigabitEthernet1/0/49" OR

TrunkPort.Description equals "GigabitEthernet2/0/49"

If so I can create a custom group for each device I am interested in changing the threshholds on.

Cisco Employee

Re: DFM custom rules - syntax problem

This won't work as expected as you'll get interface GigabitEthernet1/0/49 from the device with name *****-3750-01.bgs.com, as well as all interfaces Gigabit2/0/49.

Community Member

Re: DFM custom rules - syntax problem

Hi,

Is is possible to create a a single rule that will monitor both ports 49 & 50 on a specific device? Or will I have to use multiple custom groups, If this is the case I don't believe there will be enough groups for the number of interfaces I wish to change the threshold on.

Cisco Employee

Re: DFM custom rules - syntax problem

What version of DFM do you have? If 3.0 or higher, complex rules should now work, but there's a catch. You have to have a space between your parentheses and the rule text. For example:

TrunkPort.SystemName equals "*****-3750-01.bgs.com" AND

( TrunkPort.Description equals "GigabitEthernet1/0/49" OR

TrunkPort.Description equals "GigabitEthernet2/0/49" )

Community Member

Re: DFM custom rules - syntax problem

Thanks for your help but I still can't get this to work. I am using DFM 3.0.4

When I use your suggested syntax the only member in the group is port 1/0/49 and not both ports 1/0/49 & 2/0/49.

Do you have any suggestions?

Cisco Employee

Re: DFM custom rules - syntax problem

It works locally for me. Make sure you resave your priority settings, then reapply changes after making any changes to the group ruleset.

Community Member

Re: DFM custom rules - syntax problem

Hi, I have tried applying this again, and still only get port 1/0/49 assigned to the group. Are there any trace logs I can view to try and solve this?

Thanks

Cisco Employee

Re: DFM custom rules - syntax problem

I wonder if port 2/0/49 is not classified as a trunk port. Find out the group to which this port currently belongs. You can do this by looking under the system-defined groups under Manage Thresholds.

Community Member

Re: DFM custom rules - syntax problem

Thanks again for your continued help with this. I have checked you suggestion and neither ports 1/0/49 or port 2/0/49 are showing as trunk ports. In actual fact port 1/0/49 is showing as an access port and 2/0/49 is not showing in any of the system groups. I have checked the device details in DFM and both ports managed state is set to true.

The switch ports are configured as trunks, I have copied their config below. Do you have any suggestion as to why they would not be showing as trunk ports in DFM?

interface GigabitEthernet1/0/49

description #####

switchport trunk encapsulation dot1q

switchport trunk native vlan 301

switchport trunk allowed vlan 301,600-613

switchport mode trunk

switchport nonegotiate

no snmp trap link-status

spanning-tree portfast

interface GigabitEthernet2/0/49

description *****

switchport trunk encapsulation dot1q

switchport trunk native vlan 100

switchport trunk allowed vlan 100,600-613

switchport mode trunk

switchport nonegotiate

no snmp trap link-status

spanning-tree portfast

Cisco Employee

Re: DFM custom rules - syntax problem

DFM classifies ports as trunk ports if they are connected to another device which DFM is managing. Else, they are classified as access ports.

Community Member

Re: DFM custom rules - syntax problem

Hi,

We are using LMS 2.6 and DFM 2.0.8.

I wish to create a DFM group in order to isolate 4 interfaces. It's 4 trunk that i wishto monitor with a utilization percentage of 70%. But keeping all other trunk at 40%.

Is it possible and how ?

Regards,

Cisco Employee

Re: DFM custom rules - syntax problem

Please start a new thread for your issue.

890
Views
5
Helpful
13
Replies
CreatePlease to create content