Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

DFM stopped device polling after upgrade

Hello!

I have LMS 3.1 . I upgraded DFM to 3.1.2 and it stopped device polling. When I try to view polling parameters for group Routers, I get message "The selected group has no devices. Please select a group with devices."

When I try to edit polling parameters or set them to factory defaults, I get message "An error occurred while applying factory polling settings and factory polling values to PTM Server. Please check the PTMClient.log file for more details."

Here is what I see in PTMClient.log:

27 Feb 2009|15:41:01.536|ERROR|PTMClient_Log|Thread-24|PtmUIHandler|createPollingReportXml|.|

Exception while creating the polling report xml

27 Feb 2009|15:44:39.255|ERROR|PTMClient_Log|Thread-24|PtmUIHandler|resetSettingsForGroup|.| Exception occured while invoking setFactoryGroupSettings CTM API[ERROR:[ERROR:com.cisco.nm.vhm.vpta.PTAException: com.cisco.nm.vhm.vpta.PTAException: PTARequestHandler :: in PTSettingDetails() ::com.cisco.nm.inchargelib.InchargeWrapperException: ICF-E-EWRONGCLASS-Requested class (Disable_Analysis_Setting) is not a

sub-class of ICF_Setting

]]

27 Feb 2009|15:44:39.255|ERROR|PTMClient_Log|Thread-24|PTMPollingAction|perform|.|

Exception occurred while applying the default settings to the backend with handler.null

27 Feb 2009|15:44:39.255|ERROR|PTMClient_Log|Thread-24|PTMPollingAction|perform|.|[ERROR:[ERROR:[ERROR:com.cisco.nm.vhm.vpta.PTAException: com.cisco.nm.vhm.vpta.PTAException: PTARequestHandler :: in PTSettingDetails() ::com.cisco.nm.inchargelib.InchargeWrapperException: ICF-E-EWRONGCLASS-Requested class (Disable_Analysis_Setting) is not a

sub-class of ICF_Setting

]]]

at com.cisco.nm.trx.ptm.client.PtmUIHandler.resetSettingsForGroup(PtmUIHandler.java:970)

at com.cisco.nm.trx.ptm.ui.PTMPollingAction.perform(PTMPollingAction.java:1700)

at org.apache.struts.action.ActionServlet.processActionPerform(ActionServlet.java:1786)

at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1585)

at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:509)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:709)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)

at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)

at com.cisco.nm.cmf.util.AccessLogFilter.doFilter(AccessLogFilter.java:100)

at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)

at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)

at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)

at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)

at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)

at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)

at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)

at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)

at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:199)

at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:282)

at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:754)

at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:684)

at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:876)

at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)

at java.lang.Thread.run(Thread.java:595)

I also enabled debug of PTM, logs are attached.

I tried to reboot and even reinstall DFM, but it was useless. Help me, please!

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: DFM stopped device polling after upgrade

Okay, I think I've managed to reproduce this. DFM 3.1.2 is HARMFUL.

I found a workaround. Go to DFM > Configuration > Polling and Thresholds > Managing Thresholds. Expand the DFM > System Defined Groups tree. Go through each Interface, Access Port, and Trunk Port group. If any of them have the box checked for " Disable All Threshold Settings for This Group" uncheck the box, and Save the setting.

Once all of the thresholds are enabled, restart PTMServer from the command line:

pdterm PTMServer

pdexec PTMServer

Now you should be able to make changes to your polling parameters.

5 REPLIES
Cisco Employee

Re: DFM stopped device polling after upgrade

I cannot reproduce. I upgraded my Solaris server from DFM 3.1.1 to 3.1.2, and I can still view and edit polling and threshold settings.

On what platform did you do the upgrade? What version of DFM were you running previously?

New Member

Re: DFM stopped device polling after upgrade

Windows 2003 Server R2 with SP2. Previous version was that comes with LMS 3.1 . DFM 3.1, I guess.

Is there a way to restore previuos version without full reinstall of LMS?

Cisco Employee

Re: DFM stopped device polling after upgrade

Okay, I think I've managed to reproduce this. DFM 3.1.2 is HARMFUL.

I found a workaround. Go to DFM > Configuration > Polling and Thresholds > Managing Thresholds. Expand the DFM > System Defined Groups tree. Go through each Interface, Access Port, and Trunk Port group. If any of them have the box checked for " Disable All Threshold Settings for This Group" uncheck the box, and Save the setting.

Once all of the thresholds are enabled, restart PTMServer from the command line:

pdterm PTMServer

pdexec PTMServer

Now you should be able to make changes to your polling parameters.

Cisco Employee

Re: DFM stopped device polling after upgrade

FYI, I filed CSCsy09263 to track this issue.

New Member

Re: DFM stopped device polling after upgrade

Thank you very much! Everything works as expected!

482
Views
0
Helpful
5
Replies
CreatePlease to create content