Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

DHCP and Bridge

Hi,

I meet a mistake with a cisco SOHO 97 and IOS 12.4.

I have a server DHCP on the router. When I bridge eth0 and ATM0 my server can not give address anywhore.

Can someone help me ?

3 REPLIES

Re: DHCP and Bridge

When you use bridiging like this, the router probably assigns dhcp on the ATM as well. When this is an Internet connection your ISP will be quite unhappy as you are assigning your adresses to his other customers.

At your end, the ip pool will be exhausted rather quickly which might explain why it does not work for your server. To make a long story short: do not try this at home!

Please post your config if this does not apply.

Regards,

Leo

New Member

Re: DHCP and Bridge

Tahnks for your answer.

Here my config

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname MyHostname

!

boot-start-marker

boot system flash soho97-k9oy1-mz.124-10a.bin

boot-end-marker

!

enable secret 5 MySecret

enable password 7 MyPassword

!

no aaa new-model

no ip routing

no ip dhcp use vrf connected

ip dhcp excluded-address 172.18.15.200 172.18.15.254

!

ip dhcp pool Client

network 172.18.15.0 255.255.255.0

default-router 172.18.15.254

dns-server 172.18.4.11 172.18.4.12

domain-name Mydomain.com

lease 42

!

!

no ip cef

!

!

!

!

!

!

!

!

interface Ethernet0

ip address 10.2.15.254 255.255.255.0 secondary

ip address 172.18.15.253 255.255.255.0

no ip route-cache

no ip mroute-cache

bridge-group 1

hold-queue 100 out

!

interface ATM0

no ip address

no ip route-cache

no ip mroute-cache

no shutdown

no atm ilmi-keepalive

dsl operating-mode auto

bridge-group 1

pvc 8/35

pppoe-client dial-pool-number 1

!

!

no ip http server

no ip http secure-server

!

!

dialer-list 1 protocol ip permit

!

control-plane

!

bridge 1 protocol dec

!

line con 0

no modem enable

stopbits 1

line aux 0

stopbits 1

line vty 0 4

password 7 MyVirtualPAssword

login

!

scheduler max-task-time 5000

end

Regards,

Julien

Re: DHCP and Bridge

Hello Julien,

I'm sorry that it took a while to get back on this one but I happen to have missed your reply.

What do you intend to realize with this config? If it is intended for internet access I am missing the nat statements. Also noticed you are using PPPoE so please check the URL below for a few configuration examples.

http://www.cisco.com/en/US/products/sw/iosswrel/ps1834/products_feature_guide09186a00800800f4.html

Regards,

Leo

287
Views
0
Helpful
3
Replies
CreatePlease to create content