Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Discovery exclude filter in LMS 4.0 not working?

Hi,

On a fresh installed LMS 4.0 (Win2008 Std 64-bit) the discovery exclude filter seems not to work as expected

Global seed device configured is 172.30.50.10

ip address exclude filter is set to

172.16.125.*

172.17.125.*

172.18.125.*

172.20.125.*

172.22.125.*

172.24.125.*

Yet, the discovery job stops

ngdiscovery.log logs

[Oct 19  14:06:34] DEBUG  [ModuleWorker : EvalTask-DiscoveryThreadPool-01 applyAllModules]  : |172.30.50.10|Module System has been marked not to be proceessed further, reason is: Device: /172.30.50.10 is filtered by IP Address filter.

The discovery job creates CSdiscovery-config.xml, contains:

IPFilter Enabled="true">
            <IPIncluded/>
            <IPExcluded>
                <IPRange IPAddress="172.16.125.*"/>
                <IPRange IPAddress="172.17.125.*"/>
                <IPRange IPAddress="172.18.125.*"/>
                <IPRange IPAddress="172.20.125.*"/>
                <IPRange IPAddress="172.22.125.*"/>
                <IPRange IPAddress="172.24.125.*"/>
            </IPExcluded>
        </IPFilter>

Everyone's tags (4)
2 REPLIES
Cisco Employee

Re: Discovery exclude filter in LMS 4.0 not working?

The exclude filter works on all IPs on a device.  If 172.30.50.10 contains any interface that contains an excluded IP, then that device will be excluded.  It looks like this might be the case here.

New Member

Re: Discovery exclude filter in LMS 4.0 not working?

Yes, this is the case

Checked the environment, this is a single router network so the seed device does have an interface address matching the exclude filter

I will exclude that address from the exclude filter

Regards,

Fredrik

446
Views
0
Helpful
2
Replies
CreatePlease to create content