Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Discovery Issuse on Cisco LMS v.2.6

Hi

My device discovery has suddenly stopped working - as in it fails to start when prompted and just goes straight back to an idle state.

Looking in the discovery.log file I have the entries below....

2007/02/09 15:01:13 main MESSAGE DiscoveryMain: Properties will be read from d:\PROGRA~1\CSCOpx\campus\etc\cwsi\DiscoveryStatus.properties

2007/02/09 15:01:13 main MESSAGE DiscoveryMain: Properties will be read from d:\PROGRA~1\CSCOpx\campus\etc\cwsi\DiscoveryStatus.properties

2007/02/09 15:01:13 main FATAL ERROR ServiceModule: undefined property: ServiceModuleList

Anyone know how to recover from this error?

3 REPLIES
Cisco Employee

Re: Discovery Issuse on Cisco LMS v.2.6

Looks like a problem with your DeviceDiscover.properties file

Lets try the following:

1. Stop the daemon managerbefore doing this,

net stop crmdmgtd

2. Go to CSCOpx\campus\etc\cwsi\

The DeviceDiscovery.properties looks to be corrupted and we need to fix it

3. Please rename DeviceDiscovery.properties to DeviceDiscovery.properties.backup

4. Then rename DeviceDiscovery.properties.orig to DeviceDiscovery.properties

Please keep a copy of DeviceDiscovery.properties.orig in case you have to ever do it again.

Edit the DeviceDiscovery.properties now

by opening with WordPad and look for the following:

DEVICESROOT=

DEVICESPACKAGE=com.cisco.nm.ani.server.devices

DeviceConfigFile=devices.xml

And change it to:

DEVICESROOT=C:\\PROGRA~1\\CSCOpx\\campus\\lib\\classpath

DEVICESPACKAGE=com.cisco.nm.ani.server.devices

DeviceConfigFile=devices.xml

5. Start the daemons

net start crmdmgtd

Wait for the daemons to start and see if you get the same error

New Member

Re: Discovery Issuse on Cisco LMS v.2.6

Hi

Of course this means that all my subnets and seed devices will be lost - is there a way to recover them, or do I need to enter them again?

Not a real hassle if I have to enter them as I have been wanting to tidy them up for ages. BTW I noted from another post that had a similar issue that the corruption occurs when you have 200+ seed devices (I had about 220 as of yesterday, but only 180 the day before when LMS last worked).

Thanks

New Member

Re: Discovery Issuse on Cisco LMS v.2.6

Hi

Of course this means that all my subnets and seed devices will be lost - is there a way to recover them, or do I need to enter them again?

Not a real hassle if I have to enter them as I have been wanting to tidy them up for ages. BTW I noted from another post that had a similar issue that the corruption occurs when you have 200+ seed devices (I had about 220 as of yesterday, but only 180 the day before when LMS last worked).

Thanks

279
Views
0
Helpful
3
Replies
CreatePlease login to create content