Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

Dynamic User update issue on LMS 3.2

Win2008 VM:

1. Campus Manager 5.2.1

2. CiscoView 6.1.9

3. CiscoWorks Assistant 1.2.0

4. CiscoWorks Common Services 3.3.0

5. Device Fault Manager 3.2.0

6. Integration Utility 1.9.0

7. LMS Portal 1.2.0

8. Resource Manager Essentials 4.3.1

hello

Setup Dynamic Updates on LMS a few months back and tested ok with a WS-C2960-24PC-L running c2960-lanbasek9-mz.122-52.SE. Dynamic Updates has now stopped working! no changes on LMS or on switch. i've attached a trace debug for MAC UHIC - i can see the mac address (sent by the 2960) ok but the process ends with "macuhic INFO MacUhicDBTransaction: No data in the MAC notification entry.getMacEventSize() is 0". i've also attached the mac notification config on the 2960.

previously i could configure the 2960 switch from LMS through the Device Trap Configuration page. now when i try this i get:

There are no ports to configure for the selected device(s).
Check whether you have selected any router(s).

any ideas on where i go from here?

thanks

andy

ps i've also rebooted server but issue persists

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Dynamic User update issue on LMS 3.2

This is exactly what I thought was the problem.  Yes, you are seeing CSCtd49439.  Contact TAC, and they can provide you the patch to fix this.  The bug can affect more than APs.  They were just one example.

4 REPLIES
Cisco Employee

Re: Dynamic User update issue on LMS 3.2

Run a full Campus Manager Data Collection, then post the ani.log.

Re: Dynamic User update issue on LMS 3.2

hello
thanks for the response. i had found the following in the MACUHIC log:

2010/10/08 16:15:33 main macuhic INFO TrapListenerFilterImpl: FileNotFoundExcpetion was caught since NMSRoot\campus\etc\cwsi\portsData.xml and NMSRoot\campus\etc\cwsi\vlanData.xml file is not found

2010/10/08 16:15:33 main macuhic INFO TrapListenerFilterImpl: FileNotFoundException occured since Campus Data Collection has not run even once

2010/10/08 16:15:33 main macuhic INFO TrapListenerFilterImpl: NullPointerException occured since there are no XML files. XML file will be generated only at the completion of Data Collection

i checked NMSRoot\campus\etc\cwsi and these files didn't exist.

i reinitialized the ANI database and done a network discovery before running a full Data Collection. Data Collection finishes but the  vlanData.xml and portsData.xml still aren't created.

when i now try and run a manual UT acquisition i get the error:

Failed to start acquisition: Construction of XML data required for UT is in progress. Please try after some time.

there are 2 autonomous AP managed by LMS but i excluded them from the Data Collection - does this sound like bug CSCtd49439?

i've attached a pdshow output - the ani.log contains a lot of IP/naming which i'll have to edit

cheers
andy

Cisco Employee

Re: Dynamic User update issue on LMS 3.2

This is exactly what I thought was the problem.  Yes, you are seeing CSCtd49439.  Contact TAC, and they can provide you the patch to fix this.  The bug can affect more than APs.  They were just one example.

Re: Dynamic User update issue on LMS 3.2

received patch from TAC. After a full Data Collection, UT and dynamic UT are working fine.

thanks

andy

600
Views
0
Helpful
4
Replies
CreatePlease to create content