Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Error editing group rules

I am unable to edit any Group Rules in Campus Manager. Even without changing anything I get the same error after clicking "next" once I'm in edit mode. I cannot get pass the "Rules".

Error evaluating group rule. One of the reasons might be that ANIDbEngine process is down:

:Campus:OGS:Device.IP.Subnet equals "10.x.x.0"..............(Application error: Error occurred in evaluating the sqlQuery java.lang.Exception: Error occurred in evaluating the sql Query java.sql.SQLException: JZ0C0: Connection is already closed.)

ANIDbEngine is running! I stopped the ANIDbEngine process, restarted it and restarted the ANIServer. All else seems to be functioning normally! Device Discovery is working as is Campus Data Collections.

Windows 2003 Server, all the latest updates for CiscoWorks.

Need help troubleshooting this. Thanks!

3 REPLIES
Cisco Employee

Re: Error editing group rules

Looks similar to this bug:

CSCsd15912

LMS 2.5 Device Group Rule limitations

http://www.cisco.com/cgibin/Support/Bugtool/onebug.pl?bugid=CSCsd15912&Submit=Search

Community Member

Re: Error editing group rules

I already use Network ID's like the "workaround" suggests. I do not use ranges or wildcards.

All the Network's were entered into the system before the upgrade.

I've tried deleting all the Networks and entering just one Network ID. Same error!

Community Member

Re: Error editing group rules

Rebooted the Server. Go figure! I hate to do that cause when I restart the server I always have a helluva time restarting the ANI Server. (or at least according to "Topology Services" it's not started)

119
Views
12
Helpful
3
Replies
CreatePlease to create content