Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ERROR:RME_CDL1031 and SSH

Hello,

I'm trying to use NetConfig on devices using SSH and I always get this errror.

ERROR:RME_CDL1031:Transport session to device failed SSH: Failed to establish SSH connection to 172.22.0.7 - Cause: Authentication failed on device 3 times. TELNET: Failed to establish TELNET connection to 172.22.0.7 - Cause: Connection refused.

I've only got SSH and TELNET enabled in RME and with SSH as the higher priority.

I've double checked the user credentials I want CW to use in Common Services... Do I need to check on other places? What could be causing this?

Regards,

Gudvardur

2 ACCEPTED SOLUTIONS

Accepted Solutions
Cisco Employee

Re: ERROR:RME_CDL1031 and SSH

Default credentials are only processed when the device is added to DCR. If you added these credentials after this device was added, it would not have inherited the default credentials.

Update DCR so that it has the correct credentials for this device, then you should be set.

Cisco Employee

Re: ERROR:RME_CDL1031 and SSH

Select the devices under Common Services > Device and Credentials > Device Management, then click the Edit Credentials button.

7 REPLIES
Cisco Employee

Re: ERROR:RME_CDL1031 and SSH

This error is almost always correct. It points to bad credentials in DCR for this device. You can do a DCR export under Common Services > Device and Credentials > Device Management to view the credentials in clear text. Then, try using those credentials from the CiscoWorks server, and make sure you can successfully get into enable mode.

New Member

Re: ERROR:RME_CDL1031 and SSH

The username and password is empty, how can that be if default credentials are specified?

Do I need to specify this somewhere else?

Cisco Employee

Re: ERROR:RME_CDL1031 and SSH

Default credentials are only processed when the device is added to DCR. If you added these credentials after this device was added, it would not have inherited the default credentials.

Update DCR so that it has the correct credentials for this device, then you should be set.

New Member

Re: ERROR:RME_CDL1031 and SSH

This worked brilliantly,

Now one last question, if I need to change credentials for multiple devices in DCR, is there a easy way to do that?

Cisco Employee

Re: ERROR:RME_CDL1031 and SSH

Select the devices under Common Services > Device and Credentials > Device Management, then click the Edit Credentials button.

New Member

Re: ERROR:RME_CDL1031 and SSH

Fantastic! Thank you so much, jclarke! :D

Merry christmas to you.. :)

New Member

Re: ERROR:RME_CDL1031 and SSH

hello,

i am running the lms under version 4.2.4 and it happens to receive the same error message:

ERROR:CONFIG_CDL1031:Transport session to device failed SSH: Failed to establish  SSH connection to .....

I have double checked that the credentials are correct for the failed device using the 1)device credential report and 2)check device credentials  . Both of them succeed for the ssh...

Any ideas?

thank you

1216
Views
0
Helpful
7
Replies
CreatePlease to create content