Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

export inventory job takes too long

Hi,

I use LMS2.5 & RME 4.0.4.

From 3 month ago the cwcli job that exports inventory to xml files takes too long (about 3 minutes for 1 export).

For example I did this command below,

        cwcli export inventory -device AAA -f "C:\temp\AAA.xml" -l AAA.log

this was the AAA.log

[ lun mar 08  10:24:26 CET 2010 ],INFO ,[main],com.cisco.nm.rmeng.util.db.DatabaseConnectionPool,getConnection,59,Inside ICSDatabaseConnection, MAX_COUNT =20
[ lun mar 08  10:24:26 CET 2010 ],INFO ,[main],com.cisco.nm.rmeng.util.db.DatabaseConnectionPool,getConnection,59,Inside ICSDatabaseConnection, MAX_COUNT =20
[ lun mar 08  10:24:26 CET 2010 ],INFO ,[main],com.cisco.nm.rmeng.util.db.DatabaseConnectionPool,getConnection,59,Inside ICSDatabaseConnection, MAX_COUNT =20
[ lun mar 08  10:24:26 CET 2010 ],INFO ,[main],com.cisco.nm.rmeng.util.db.DatabaseConnectionPool,getConnection,59,Inside ICSDatabaseConnection, MAX_COUNT =20
[ lun mar 08  10:24:26 CET 2010 ],INFO ,[main],com.cisco.nm.rmeng.util.db.DatabaseConnectionPool,getConnection,59,Inside ICSDatabaseConnection, MAX_COUNT =20
[ lun mar 08  10:24:26 CET 2010 ],INFO ,[main],com.cisco.nm.rmeng.util.db.DatabaseConnectionPool,getConnection,59,Inside ICSDatabaseConnection, MAX_COUNT =20
[ lun mar 08  10:24:26 CET 2010 ],INFO ,[main],com.cisco.nm.rmeng.util.db.DatabaseConnectionPool,getConnection,59,Inside ICSDatabaseConnection, MAX_COUNT =20
[ lun mar 08  10:24:26 CET 2010 ],INFO ,[main],com.cisco.nm.rmeng.util.db.DatabaseConnectionPool,getConnection,59,Inside ICSDatabaseConnection, MAX_COUNT =20
[ lun mar 08  10:27:36 CET 2010 ],INFO ,[main],com.cisco.nm.rmeng.cli.export_inventory$1,info,123,
Took 3782 ms (3 sec) with hop 1
[ lun mar 08  10:27:36 CET 2010 ],INFO ,[main],com.cisco.nm.rmeng.cli.export_inventory$1,info,123,
Took 3782 ms (3 sec) with hop 1
[ lun mar 08  10:27:36 CET 2010 ],INFO ,[main],com.cisco.nm.rmeng.cli.export_inventory$1,info,123,
Took 3782 ms (3 sec) with hop 1
[ lun mar 08  10:27:36 CET 2010 ],INFO ,[main],com.cisco.nm.rmeng.cli.export_inventory$1,info,123,
Took 3782 ms (3 sec) with hop 1
[ lun mar 08  10:27:36 CET 2010 ],INFO ,[main],com.cisco.nm.rmeng.cli.export_inventory$1,info,123,
Took 3782 ms (3 sec) with hop 1
[ lun mar 08  10:27:36 CET 2010 ],INFO ,[main],com.cisco.nm.rmeng.cli.export_inventory$1,info,123,
Took 3782 ms (3 sec) with hop 1
[ lun mar 08  10:27:36 CET 2010 ],INFO ,[main],com.cisco.nm.rmeng.cli.export_inventory$1,info,123,
Took 3782 ms (3 sec) with hop 1
[ lun mar 08  10:27:36 CET 2010 ],INFO ,[main],com.cisco.nm.rmeng.cli.export_inventory$1,info,123,
Took 3782 ms (3 sec) with hop 1
[ lun mar 08  10:27:36 CET 2010 ],INFO ,[main],com.cisco.nm.rmeng.cli.export_inventory$1,info,123,
Took 3782 ms (3 sec) with hop 1

The export job creats an xml-file correctly but it takes too long.

I have no idea what I can do to fix this problem. help

1 REPLY
Cisco Employee

Re: export inventory job takes too long

You are using a very old version of RME.  LMS 2.5 and 2.5.1 will be end of support this June.  You really need to upgrade to at least LMS 2.6.

The problem you are seeing is CSCse14096 which is fixed in LMS 2.6 (RME 4.0.5).

191
Views
0
Helpful
1
Replies