Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Fail to generate EoL/EoS Hardware Report

Hi All,

I tried to generate EoL/EoS Hardware Report through RME Report Generator. Even with correct cisco.com user name and password and correct proxy server configuration. It just keeps telling me it can't get data from cisco.com. I configured proxy server and port used in Common Service/Security. I tried to check the update for software to verify the proxy setting is correct. It didn't return any error. So the proxy setting has no problem.

Is there anything I missed? Thanks a lot!

Lou

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Fail to generate EoL/EoS Hardware Report

Yes, but that is due to a bug I forgot to mention in the doc which is CSCta76147.

26 REPLIES
Cisco Employee

Re: Fail to generate EoL/EoS Hardware Report

New Member

Re: Fail to generate EoL/EoS Hardware Report

We are using proxy server to access cisco.com. So that means I need wait until the summer to get the patch for this issue, right?

Thanks a lot!

Cisco Employee

Re: Fail to generate EoL/EoS Hardware Report

Yes, but that is due to a bug I forgot to mention in the doc which is CSCta76147.

Cisco Employee

Re: Fail to generate EoL/EoS Hardware Report

Actually, it appears the patches mentioned in my doc do fix the two proxy bugs (despite the lack of documentation to that effect).  I am confirming with development, but if you haven't already downloaded, and installed the patch, go ahead and do so.

New Member

Re: Fail to generate EoL/EoS Hardware Report

Thanks Joe. I'm applying the patch now. See what will happen. The stopping process is too slow.

New Member

Re: Fail to generate EoL/EoS Hardware Report

After I successfully apply 4.30 patch to my ciscoworks. I restarted the server and then I got the below error when I tried to access the ciscoworks webpage. Is the patch still doing something? I restarted the daemon manager. It didn't help.

503 Service Temporarily Unavailable

Service Temporarily Unavailable

The server is temporarily unable to service your request due to maintenance  downtime or capacity problems. Please try again later.

Cisco Employee

Re: Fail to generate EoL/EoS Hardware Report

That doesn't make sense.  The patch would not affect the core services unless something catastrophic happened.  After restarting Daemon Manager, post the output of the pdshow command when it finally returns the process list.

New Member

Re: Fail to generate EoL/EoS Hardware Report

Never mind. That is only slowness. I need wait for some time until the system fully works. I just checked the EoL report. It still doesn't work and tell me the same reason "Unable to get data from Cisco.com. Check Cisco.com connectivity. Try again later". It seems the patch doesn't fix the problem.

Cisco Employee

Re: Fail to generate EoL/EoS Hardware Report

Post the invreports.log and the job log (from the job subdirectory under NMSROOT/files/rme/jobs/inventory/reports/jobs) after running the report job.

New Member

Re: Fail to generate EoL/EoS Hardware Report

The log files are attached. I tried eol report at 08:08 AM. Thanks Joe.

Cisco Employee

Re: Fail to generate EoL/EoS Hardware Report

This looks like a database issue.  Enable Inventory Reports debugging under RME > Admin > System Preferences > Application Loglevel Settings, then reproduce the problem, and repost the invreports.log.

New Member

Re: Fail to generate EoL/EoS Hardware Report

Here we go. updated invreports.log

Cisco Employee

Re: Fail to generate EoL/EoS Hardware Report

This is showing a connection refused error.  It looks like your proxy is being configured, but there may still be an issue there.  First, make sure that the proxy server settings are 10.1.1.87:8080.  Then, get a sniffer trace of all TCP traffic from the LMS server while running the EOX report.  Post the sniffer trace file when the job fails.

New Member

Re: Fail to generate EoL/EoS Hardware Report

Sorry for the late. I was able to capture the trace yesterday. Trace file attached.

Thanks. I see the cookie setup thing from the proxy server.

Cisco Employee

Re: Fail to generate EoL/EoS Hardware Report

I have been doing some testing locally, and found that proxy support is, in fact, still broken.  The PSIRT/EoX code will still attempt to make a direct connection to Cisco.com to download a PSIRT_EOX.properties file.  We are investigating this currently.

New Member

Re: Fail to generate EoL/EoS Hardware Report

Thanks Joe.

New Member

Re: Fail to generate EoL/EoS Hardware Report

Hi Joe,

We don't need proxy to go to the internet right now. So the job to create a EoS report succeeded. But the attached pdf file doesn't have any record about EoS or EoL. I'm sure some devices in our network are pretty old which should be listed in the report. Do you any thought about this blank report?

Thanks.

Lou

Cisco Employee

Re: Fail to generate EoL/EoS Hardware Report

You should first download the latest copy of the patch as there were some more fixes rolled in.  Next, if you have RME < 4.3 you may be seeing CSCsz19286.  If you are affected by that bug, running the report on a subset devices will download only a subset of the data.  A new copy of the data (for newer devices) will not happen until the timer pops.  The workaround is to wait for the download timer to pop to make sure the full set of EoX data is downloaded.  Alternatively, you can use the offline data files.

http://cdetsweb-prd.cisco.com/apps/goto?identifier=CSCsz19286

New Member

Re: Fail to generate EoL/EoS Hardware Report

Thanks Joseph. But where is the patch I can download? In addition, the link http://cdetsweb-prd.cisco.com/apps/goto?identifier=CSCsz19286 doesn't work at this time.

My RME is 4.3.0 version now. I tried to update RME in CiscoWorks. It told me there is no update available for RME. I assume my version is latest, right?

Thanks a lot for your help.

Lou

Cisco Employee

Re: Fail to generate EoL/EoS Hardware Report

See this document for patches and data file locations.

https://supportforums.cisco.com/docs/DOC-9080

New Member

Re: Fail to generate EoL/EoS Hardware Report

Thanks Joseph. Should I just apply the patch "rme4.3.1-win-CSCtj03361-1.0.tar" on 06/DEC/2010?

Lou

Cisco Employee

Re: Fail to generate EoL/EoS Hardware Report

You'll want to update to RME 4.3.1 first.  RME 4.3.1 can be downloaded from Common Services > Software Center > Software Update.

New Member

Re: Fail to generate EoL/EoS Hardware Report

I tried again but Ciscoworks told me there is no update for the product I selected.

Is there any other way to do that? My LMS version is 3.2. Thanks a lot for your help!

Cisco Employee

Re: Fail to generate EoL/EoS Hardware Report

You can download 4.3.1 directly from http://www.cisco.com/cisco/software/release.html?mdfid=282635175&flowid=5145&softwareid=280775120&os=Windows . If you continue to have problems, start a new thread.

New Member

Re: Fail to generate EoL/EoS Hardware Report

Hello Joe,

is there a fix interval when PSIRT and EoX offline files will be updated on Cisco Software-Download?

As of now the timestamp of EoX/PSIRT-Files is 05th of April.

Thanks for your feedback

Link (http://tools.cisco.com/support/downloads/go/ImageList.x?relVer=4.1.1&mdfid=282635175&sftType=CiscoWorks+Resource+Manager+Essentials+Patches&optPlat=Solaris&nodecount=8&edesignator=null&modelName=CiscoWorks+Resource+Manager+Essentials+4.3&treeMdfId=26...)

Cisco Employee

Re: Fail to generate EoL/EoS Hardware Report

The files were supposed to be updated every two weeks.  I'll check with development as to why they weren't updated last week.

1674
Views
20
Helpful
26
Replies
CreatePlease login to create content