Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Flushing / Deleting Devices from Cisco Prime LMS4.1 - How ?

Hello,

Discovery got a little messed up when importing from LMS 3.1

Basically I want to flush all devices from all the different LMS modules.

If I delete all devices from Device Management they seem to stay in Topology Services / Device Discovery / Data Collection etc.. They keeps the old device in their own database.

Is there a way of flushing all devices from all these different modules. I'm going to re-import them with a clean CSV import file.

Cheers

Barry

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Flushing / Deleting Devices from Cisco Prime LMS4.1 - How ?

Re-initailizing the cmf database will clear out everything. Please see the procedures posted here.

Hope this helps.

5 REPLIES
Hall of Fame Super Silver

Flushing / Deleting Devices from Cisco Prime LMS4.1 - How ?

Re-initailizing the cmf database will clear out everything. Please see the procedures posted here.

Hope this helps.

New Member

Flushing / Deleting Devices from Cisco Prime LMS4.1 - How ?

Thanks Mate,

All devices are now purged. However, I still see all my devices in the Device Discovery sumary. Can't seem to rid these.

Cheers

Barry

Hall of Fame Super Silver

Flushing / Deleting Devices from Cisco Prime LMS4.1 - How ?

Hmm, I'd have thought the cmf re-init would knock them out. Have you tried "Inventory > Device Administration > Add / Import / Manage Devices", select "All Devices" then "Delete"?

New Member

Flushing / Deleting Devices from Cisco Prime LMS4.1 - How ?

Yeah, Did all that. Even reboot after.

The reason I'm doing all this is because when I bulk imported all my devices from 3.1 for some reason 4.1 took all the IP addresses as host name and as such when I get alert or reports it's the IP address I get when I really need the hostname.

I edited the import CSV file and for some LMS applications I get the hostname for the device name and for others I get the IP adress shown as the hostname which is confusing for the OPS team.

I'm avoiding a rebuild as it take me quite a few hours to do this.

Cheers

Barry

Hall of Fame Super Silver

Flushing / Deleting Devices from Cisco Prime LMS4.1 - How ?

It is confusing to everybody I think (except perhaps Joe Clarke). Perhaps Joe will jump in with a solution to this last bit.

Starting back when CiscoWorks instituted a DCR (ca. CiscoWorks 2000?) things began to integrate across the components but under the covers there are still separate bits. Alerts (e.g., those from Fault functions or the old DFM, based on the EMC SMARTS product) are notorious for using settings and a repository different from the rest of the suite. I've had good luck using a local hosts file for that component to work properly (i.e., generate fault records with the proper host name vs. the device IP).

847
Views
0
Helpful
5
Replies