Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

I can not login to CW LMS

Hi there,

I have two identical CiscoWorks 2000 servers with the following components installed:

- CW Common Services SP3 2.2

- Monitoring Center for Performance 2.0.2

- IPS Management Center 2.1

- Resource Manager Essentials 3.5

- Resource Manager Essentials Incremental Device Support 3.5

- Security Monitor 2.1

At the begining there was no problem to login to these two servers, but now I can't login to one of the servers. The client browser loads the homepage, when I tried to login username and password everything stops. Then I checked the difference between two servers CW homepages, I found that, cookies are disabled in the server that I can't login. How can I start it on the server side?

Is there any idea about the situation?

Regards,

yasemin.

15 REPLIES
Cisco Employee

Re: I can not login to CW LMS

On the server that isn't working, try restarting JRunProxyServer from the cli:

pdterm JRunProxyServer

pdexex JRunProxyServer

Wait 5-10 mins and then try to login

New Member

Re: I can not login to CW LMS

Hi Davistan,

Unfortunately there is no change in the situation. I tried to stop and start the crmdmgtd after JRunProxyServer but nothing has changed :(

yasemin

Cisco Employee

Re: I can not login to CW LMS

What browser are you using? What version of the Java Plug-in? What are the contents of the Java Plug-in Console?

What are your browser's cookie settings (i.e. perhaps you are only accepting cookies from the other CW server)? Make sure your browser's security settings are the same for both CW servers.

New Member

Re: I can not login to CW LMS

I'm using different clients and different browsers. MS IE, Mozilla etc. All browsers and different Java plug-ins don't change the result. Cookies are always disabled on one of the server's CW homepage. It's disabled even on server itself.

Shutting down and restarting the server or stop/start crmdmgtd service doesn't help me. But there must be a solution.

Regards,

yasemin.

Silver

Re: I can not login to CW LMS

Hi Yasemin,

just to be sure: Did you checked the cookie seetings within your browsers?

For IE6 e.g.:

1. Choose "Tools" - "Internet Options".

2. From the "Internet Options" multi-tabbed dialog box that appears, select the "Privacy" tab.

3. Click the "Advanced" button

4. Have a look on the settings:

To be sure tick the box for "OVerride automatic cookie handling" and set the cookie settings to "Accept".

5. Press "OK" and close both dialog boxes when done.

Firefox 2 (Not supporte for LMS 2.6 and earlier):

1. Choose "Tools" - "Options".

2. Select the "Privacy" Icon.

3. in the section "Cookies" tick the box beside "Accept cookies from sites".

4. Press "OK" and close the dialog box when done.

Best regards,

Frank

New Member

Re: I can not login to CW LMS

Hi Frank,

I did it for IE, there is no difference: cookies are again disabled; after I login username and password, and click on "connect" button. The window waits forever. But the bad thing is, I can not login to server even from server's own desktop and IE running on it.

Regards,

Yasemin.

Silver

Re: I can not login to CW LMS

Even from the desktop using http://127.0.0.1:1741 ? If that doesn't work you'll need to re-install.

Silver

Re: I can not login to CW LMS

I neglected to ask if it was in https mode, if so attempting to get to https://127.0.0.1:1741

Cisco Employee

Re: I can not login to CW LMS

Please post the Java Plug-in console output as well as the NMSROOT/objects/jrun/jsm-cw2000/logs/stdout.log and stderr.log.

New Member

Re: I can not login to CW LMS

Hi,

The logs are attached.

Thank you.

yasemin

Cisco Employee

Re: I can not login to CW LMS

I've seen something like this once before when the server administrator tied down the cookie policy using the IE Admin Kit. The workaround was to run the CiscoWorks Apache server as Administrator. To do this, go to Services, and get properties on the CW2000 Web Server service. Select the Log On tab, and set it to "This account". Put in Administrator and Administrator's password. Then, log in as Administrator, go to Internet Options, and make sure all cookies are ALLOWED. Then reboot the server.

New Member

Re: I can not login to CW LMS

:(

There is no change.

Cisco Employee

Re: I can not login to CW LMS

Use an external client to connect to the server, and get a sniffer trace of all TCP port 1741 traffic between the client and the server. Post that trace file. Note: if that data is too sensitive to be posted to an open forum, please open a TAC service request, and include the trace file.

New Member

Re: I can not login to CW LMS

I solved the problem by stopping and restarting the "CiscoWorks Deamon" from services. This may be an installation problem. May be some services don't start in the regular order.

Any idea?

Best regards,

Yasemin.

Cisco Employee

Re: I can not login to CW LMS

Please provide your service startup parameters (multiple screenshots of the services control panel will work).

208
Views
0
Helpful
15
Replies