Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Incompatible Java Runtime Version

Hi,

I installed Ciscoworks LMS 3.0 on our client's server and upon login I installed the Java Plug-in from Topology services. It did work and I was able to view the topology of the devices that I have discovered. Problem is when I updated the application with the Dec 2007 update, it reinstalled again the same Java version from the Topology services window, and now I'm receiving Incompatible Java Runtime Version and Mismatch in Java Runtime Version when I go to Topology Services.

How can I resolve this? Even if I uninstall Java from Add/Remove Programs, I get the same results.

7 REPLIES
Cisco Employee

Re: Incompatible Java Runtime Version

With LMS 3.0.1, you need JPI 1.5.0_13. Uninstall all versions of Java from the client. Transfer NMSROOT/htdocs/plugin/jre-1_5_0_13-windows-i586-p_withvbj.exe from the server to the client. Install that version of the JPI as a local Administrator on the client. You should be set.

Re: Incompatible Java Runtime Version

Make sure the Java mentioned by JClarke is selected in your Browser Properties. IE >> Internet Options >> Advanced >> Java. If none is selected there the 'System' Java version is used. You can check the system java version in Control Panel >> JAVA

Regards

Farrukh

New Member

Re: Incompatible Java Runtime Version

Hey guys,

Topologgy services worked for Java update 1.5.0_13.

Thanks!

New Member

Re: Incompatible Java Runtime Version

Any news if this will be upgraded? Since most desktops automatically or already have java 1.6.0_x these days. And Topology Overview doesnt work with that version.

Cisco Employee

Re: Incompatible Java Runtime Version

LMS 3.1 includes support for Java Web Start 1.6.0_5 (i.e. Java 6 patch 5).

New Member

Re: Incompatible Java Runtime Version

Ah ok, how can we get this bundle update since I noticed this not available as download. As it was before with 2.5 -> 2.6.1

Cisco Employee

Re: Incompatible Java Runtime Version

If you have a SAS contract covering LMS 3.0, you can go to http://www.cisco.com/upgrade/ and request a copy. You can also contact your sales team.

997
Views
0
Helpful
7
Replies
CreatePlease to create content