Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Installing IPM 2.6 on Solaris 8 - Error : looking for older version

Hey guys,

I have a server that had Common Services 2.2 installed, but nothing else. So i upgraded 2.2 to 3.0, then installed all the other modules for LMS 2.5 (DFM, Campus Manager, RME) but when i go to install IPM, im getting a strange error. Here is the Log

______ LOG ______

INFO: This product requires:

RAM 524288 K

SWAP 1048576 K

INFO: Checking RAM... OK.

INFO: Checking Swap... OK.

INFO : Checking the - "casusers" group ... OK

INFO : Checking the - "casuser" account ... OK

INFO: Checking your release... All components present.

ERROR: The system reported that /opt/CSCOipm/install/version

ERROR: is missing. The existing version

ERROR: of CSCOipm-s is not properly installed.

INFO: The following Version of IPM - Server is installed:

Reinstall is not supported with this configuration.

Reinstall of the same version of IPM is not supported.

IPM Server Reinstall Canceled!!

_____ END OF LOG _____

now why is IPM looking for an old version of IPM, its never been installed on this system before. i even checked the pkg's installed, no CSCOipm, and the /opt/ directory only has CSCOpx, no IPM...so why is my install of 2.6 lookign for it?????

Any help would be nice.

13 REPLIES
Cisco Employee

Re: Installing IPM 2.6 on Solaris 8 - Error : looking for older

Regardless of what's in /opt, if the following command succeeds, then IPM will assume it's doing an upgrade:

pkginfo -q CSCOipm-s

Try running:

pkginfo CSCOipm-s

You should see a hit. If you do:

pkgparam CSCOipm-s BASEDIR

That should tell you where it was installed. If that path does not exist, pkgrm CSCOipm-s, then try to install IPM again.

Community Member

Re: Installing IPM 2.6 on Solaris 8 - Error : looking for older

did that...here is the output

# pkgrm CSCOipm-s

pkgrm: ERROR: no package associated with

Upon reinstallation, i get the same error where it thinks its a reinstall...im so confused.

---- log file -----

INFO: This product requires:

RAM 524288 K

SWAP 1048576 K

INFO: Checking RAM... OK.

INFO: Checking Swap... OK.

INFO : Checking the - "casusers" group ... OK

INFO : Checking the - "casuser" account ... OK

INFO: Checking your release... All components present.

ERROR: The system reported that /opt/CSCOipm/install/version

ERROR: is missing. The existing version

ERROR: of CSCOipm-s is not properly installed.

INFO: The following Version of IPM - Server is installed:

Reinstall is not supported with this configuration.

Reinstall of the same version of IPM is not supported.

IPM Server Reinstall Canceled!!

---- end of log file -----

Cisco Employee

Re: Installing IPM 2.6 on Solaris 8 - Error : looking for older

Do this:

# csh

# pkginfo -q CSCOipm-s

# echo $status

What is the output?

Community Member

Re: Installing IPM 2.6 on Solaris 8 - Error : looking for older

# csh

cw2k2# pkginfo -q CSCOipm-s

cw2k2# echo $status

1

the output, as shown above....is 1

Cisco Employee

Re: Installing IPM 2.6 on Solaris 8 - Error : looking for older

Strange. This should not happen. Try running the installer as:

cd /cdrom/cdrom0

sh -x ./setup.sh

Then send the output.

Community Member

Re: Installing IPM 2.6 on Solaris 8 - Error : looking for older

INFO: This product requires:

RAM 524288 K

SWAP 1048576 K

INFO: Checking RAM... OK.

INFO: Checking Swap... OK.

INFO : Checking the - "casusers" group ... OK

INFO : Checking the - "casuser" account ... OK

INFO: Checking your release... All components present.

ERROR: The system reported that /opt/CSCOipm/install/version

ERROR: is missing. The existing version

ERROR: of CSCOipm-s is not properly installed.

INFO: The following Version of IPM - Server is installed:

Reinstall is not supported with this configuration.

Reinstall of the same version of IPM is not supported.

IPM Server Reinstall Canceled!!

+ viewlog /var/tmp/cisco_ipmsvr_install.log

+ [ = -n ]

+ echo

+ echo Would you like to view the log? [ n ] -> \c

Would you like to view the log? [ n ] -> + read x

n

+ [ n = y -o n = Y ]

+ /usr/bin/clear

+ echo

+ ReadEtcVarFiles

IR=/opt/CSCOipm

IC=/opt/CSCOipmClient

IS=/opt/CSCOcwbS

+ [ -f /etc/CSCOipm.sh ]

+ [ -f /opt/CSCOipm/install/version ]

+ echo

+ echo Server install unsuccessful.

Server install unsuccessful.

+ echo Exiting...

Exiting...

+ exit 1

Cisco Employee

Re: Installing IPM 2.6 on Solaris 8 - Error : looking for older

This is not the output I expect. I do not see the debugging from the failing part of the script. When I run the same command here, I get much different output:

PATH=/sbin:/usr/sbin:/usr/bin:/usr/ucb:/etc:.:/usr/bin:/usr/sbin:/usr/ucb:/usr/openwin/bin:/usr/dt/bin:/usr/java1.2/bin:/usr/local/bin:/opt/csw/bin:/opt/csw/gcc3/bin:/opt/CSCOpx/bin:/opt/CSCOipm/bin:/export/home/marcus/bin:/usr/ccs/bin:.

+ export PATH

IPM_USER=casuser

IPM_GROUP=casusers

IPM_CASUSER_PERMS=660

IPM_CASDIR_PERMS=770

+ pwd

pdir=/cdrom/ipm_2.6

+ [ 0 -ne 0 ]

+ /usr/bin/dirname ./setup.sh

+ cd .

+ uname -s

OS=SunOS

+ [ SunOS = AIX ]

+ [ SunOS = SunOS ]

+ checkroot

+ /usr/ucb/whoami

ID=root

+ [ root != root ]

+ /usr/bin/clear

+ CheckForUpgrade

+ IsPkgInstalled CSCOipm-s

+ pkginfo -q CSCOipm-s

+ return 0

+ [ 0 -ne 0 ]

UPGRADE=TRUE

+ [ TRUE = TRUE ]

+ ReadEtcVarFiles

IR=/opt/CSCOipm

IC=/opt/CSCOipmClient

IS=/opt/CSCOcwbS

+ [ -f /etc/CSCOipm.sh ]

+ . /etc/CSCOipm.sh

IR=/opt/CSCOipm

+ export IR

IS=/opt/CSCOcwbS

+ export IS

IC=/opt/CSCOipmClient

+ export IC

+ export IR

VER_FILE=/opt/CSCOipm/install/version

+ [ ! -f /opt/CSCOipm/install/version ]

+ echo ERROR: The system reported that /opt/CSCOipm/install/version

ERROR: The system reported that /opt/CSCOipm/install/version

+ echo ERROR: is missing. The existing version

ERROR: is missing. The existing version

+ echo ERROR: of CSCOipm-s is not properly installed.

ERROR: of CSCOipm-s is not properly installed.

+ exit 1

From where are you installing IPM? What are the contents of the install/version file on the CD?

Cisco Employee

Re: Installing IPM 2.6 on Solaris 8 - Error : looking for older

I think I see what's going on now. Do the same operations for the CSCOcwbS package as you did for CSCOipm-s. You may have had (or have) CiscoWorks Blue installed on this server.

Community Member

Re: Installing IPM 2.6 on Solaris 8 - Error : looking for older

# csh

cw2k2# pkginfo -q CSCOcwbS

cw2k2# echo $status

0

so the status is 0

Cisco Works Blue?

Cisco Employee

Re: Installing IPM 2.6 on Solaris 8 - Error : looking for older

Well, it could be leftover from an old CWB installation. Use the pkgparam command I mentioned earlier to see if the basedir is still valid.

Community Member

Re: Installing IPM 2.6 on Solaris 8 - Error : looking for older

cw2k2# pkgparam CSCOcwbS BASEDIR

/opt/CSCOcwbs

So does that mean it has memory of it being installed at one point...i talked to the customer and they have no memory of having installed it. With that being said, how do i fix it?

Community Member

Re: Installing IPM 2.6 on Solaris 8 - Error : looking for older

# pkginfo CSCOcwbS

application CSCOcwbS Cisco IPM Common Services

now that is interesting...it says it's installed, but the BASEDIR location it points to doesn't exist.

I tried to run the uninstall from the IPM software CD

***************************************************************

Uninstalling IPM Server - Version

***************************************************************

pkgrm: ERROR: no package associated with

This package contains scripts which will be executed with super-user

permission during the process of removing this package.

Removal of was suspended (interaction required).

No changes were made to the system.

Thank you for using Cisco Internetwork Performance Monitor!!

I feel snookered here.

--- More information on the CSCOcwbs ----

# pkginfo -l CSCOcwbS

PKGINST: CSCOcwbS

NAME: Cisco IPM Common Services

CATEGORY: application

ARCH: sparc

VERSION: 2.5.0

BASEDIR: /opt/CSCOcwbs

VENDOR: Cisco Systems, Inc

DESC: Cisco IPM Common Services

PSTAMP: rme33-u1020030417180005

INSTDATE: Nov 05 2004 03:42

HOTLINE: 1-800-553-2447

EMAIL: tac@cisco.com

STATUS: partially installed

FILES: 210 installed pathnames

510 partially installed pathnames

110 directories

583 executables

452024 blocks used (approx)

# cd /opt/CSCOcwbs

bash: cd: /opt/CSCOcwbs: No such file or directory

#

Community Member

Re: Installing IPM 2.6 on Solaris 8 - Error : looking for older

i solved my own problem...i manually uninstalled the Srv and it uninstalled cwbS for me

-----

# ./uninstallSvr.sh

=========================================================================

=================- IPM Server Uninstall Tool Started ====================

=========================================================================

Started : Wed Sep 20 17:28:29 GMT 2006

Host : SunOS cw2k2 5.8 Generic_117350-10 sun4u sparc SUNW,Sun-Fire-V210

cat: cannot open /opt/CSCOipm/install/version

Version :

=========================================================================

Uninstalling IPM Server will remove the existing database, seed

files and other IPM configuration information from this system.

If you wish to have your existing IPM database saved, you should

stop the servers and copy the database file to a safe location.

If you wish to remove all collectors defined by this IPM Server

from the source routers supporting those collectors, please

run the following command before uninstalling this IPM Server...

ipm rmcoll

Please give ample time for the IPM Server to contact each source

router and remove the collectors before continuing the uninstall.

As an alternate method, you may finish uninstalling now and then

issue the folloowing router command on each source router...

rtr reset

In order to issue this command you must login to each source router

and enter config mode.

Continue IPM Server Uninstall? [n] y

INFO: Checking for IPM Server packages on the system. Please wait...

INFO: The following Cisco IPM Server packages are installed.

CSCOcwbS

INFO: Invoking pkgrm on IPM Server packages...

INFO: Wed Sep 20 17:28:32 GMT 2006 : Now removing CSCOcwbS...

Removal of was successful.

INFO: The following Cisco IPM

INFO: packages have been successfull deleted from the system:

CSCOcwbS

Please review /var/tmp/cisco_ipmsvr_uninstall.log for detailed results.

-----

i am not installing without an issue, thanks for your help

166
Views
5
Helpful
13
Replies
CreatePlease to create content