Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Inventory collection failed

When I run the job for inventory collection some of my devices fail witht he error "Device Collection Failed" I see these devices are fully managed in RME, I'm able to verify credential and able to run netconfig job for these devices but fail in inventory collection. Can someone point me to the right troubleshooting steps.

Thanks.

5 REPLIES
New Member

Re: Inventory collection failed

Hi

I have problem same as u before . I try to update RME 4.0.3 to 4.0.4 , It can solve the problem

Thanks

Ittipol.c

Cisco Employee

Re: Inventory collection failed

This is probably due to CSCsd17366 which impacts RME 4.0.3

This is fixed in 4.0.4, but here's a workaround for 4.0.3:

To obtain the current System Inventory job IDs, go to Common Services > Admin > Job

Browser and show only SysInvCollection or SysInvPoller.

The job ID will be the number to the left of the decimal point. For example, if the "Job

ID" column shows "1005.126", the job ID is "1005".

From a command line on the server, run the following command:

Solaris:

-----------

NMSROOT/bin/cwjava -cw NMSROOT com.cisco.nm.cmf.jrm.jobcli

Windows:

---------------

NMSROOT\bin\cwjava -cw NMSROOT com.cisco.nm.cmf.jrm.jobcli

(Note: NMSROOT above should be the path into which CiscoWorks was installed. The defaults

are /opt/CSCOpx on Solaris and C:\PROGRA~1\CSCOpx on Windows.)

Once the jobcli program connects to JRM, the following will be seen on the terminal:

Established connection with JRM

Enter "exit" to quit the CLI

At this point, type "delete ". For example, if the job ID is 1005, run:

delete 1005

Once both System Inventory jobs have been deleted, type "exit" to leave the jobcli.

Finally, log back into CiscoWorks, and go to Resource Manager Essentials >

Administration > Inventory > System Job Schedule, and reschedule the jobs.

This should get polling working again so that your jobs will run correctly.

New Member

Re: Inventory collection failed

Thanks guys.

I have tried the recommended solution but I got the following error, is there something wrong in my script?

Soalris9>> /opt/CSCOpx/bin/cwjava -cw opt/CSCOpx com.cisco.nm.cmf.jrm.jobcli

Exception in thread "main" java.lang.NoClassDefFoundError: com/cisco/nm/cmf/jrm/jobcli

Cisco Employee

Re: Inventory collection failed

Could be do to a missing /

notice that you have opt/CSCOpx instead of /opt/CSCOpx

New Member

Re: Inventory collection failed

Hi,

I had a similar problem and found it was due to IOS 12.3(1a). See CSCdx50192 for affected versions. There is no fix other than to upgrade.

449
Views
5
Helpful
5
Replies
CreatePlease to create content