Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Inventory collection fails when module removed

I currently see inventory collection fail on two 4510Es which have one of their modules removed because of hardware failure.

In IC-Server.log I see "ERROR,[Thread-33],com.cisco.nm.rmeng.util.logger.RMELogger,770,com.cisco.nm.rmeng.inventory.ics.invchange.AddInvChange,effect,

33,Unexpected error:com.sybase.jdbc2.jdbc.SybSQLException: ASA Error -193: Primary key for table 'PhysicalAssetData' is not unique""

This happens on both LMS3.01 and 3.1. Is this a known bug?

Will the problem disappear once the missing modules get replaced?

4 REPLIES
Cisco Employee

Re: Inventory collection fails when module removed

No, not to my knowledge. All similar inventory bugs should be fixed in LMS 3.1. I haven't heard of anyone else reporting this problem. Inventory problems like this are tricky to diagnose, and I don't have any 4500s with which I can test. I suggest you open a TAC service request so that this problem can be analyzed further.

New Member

Re: Inventory collection fails when module removed

Thanks Joe, but I don't feel lucky enough today to open another SR. ;)

Deleting and re-importing the device seems to help, though I hate to use this method.

New Member

Re: Inventory collection fails when module removed

Just for the record - I've opened SR 610596225 and it looks like another bug might be filed soon.

New Member

Re: Inventory collection fails when module removed

BugID: CSCsy89484

Title: Inventory collection of 4510E fails after remove/readd power supply

Status: Fixed (Release-Pending)

112
Views
4
Helpful
4
Replies
CreatePlease to create content