Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Inventory collection not working since upgrade to LMS 2.6

Hi,

I'm running Ciscoworks LMS 2.6 with RME 4.0.5.

Since upgrading to LMS 2.6 all Inventory Scheduled jobs fail and all manual update inventory jobs fail with the message:

ICSJ0008: Request to collect inventory failed.

I have stopped and started the ICServer many times and reinstalled LMS 2.6 but still no success.

Any ideas?

Cheers,

Grant

6 REPLIES
New Member

Re: Inventory collection not working since upgrade to LMS 2.6

double check your DeviceDiscovery.properties file. Not sure of why, but I have seen this get clobbered in the past. A typical LMS install will also install a backup copy of this called DeviceDiscovery.properties.orig on your LMS server (assuming Windows version).

If your evaluation of your file leads you to think it is incomplete, you'll have to copy the .orig file over the production file, stop and restart the crmdmgtd service, verify the snmp settings and the seed devices via the GUI.

Charlie

Cisco Employee

Re: Inventory collection not working since upgrade to LMS 2.6

Check the IC_Server.log for more details. There will most likely be a Java exception in there, or some error explaining why collection could not run.

New Member

Re: Inventory collection not working since upgrade to LMS 2.6

I checked the file and there was no output for the time when I tried to run a discovery.

This is the failed job list for the last 5 Inventory jobs:

1. 2226 Inventory Co

llection Failed(0) Update Inventory

from Device Cen

ter admin Oct 25 2006 15:23:20 Oct 25 2006 15:23:23 Immediate

2. 2225 Inventory Co

llection Failed(0) Update Inventory

from Device Cen

ter admin Oct 25 2006 15:05:26 Oct 25 2006 15:05:29 Immediate

3. 2222 Inventory Co

llection Failed(0) Scheduled by Pol

ling Job 1041.46

9 admin Oct 25 2006 12:09:53 Oct 25 2006 12:09:56 Immediate

4. 2220 Inventory Co

llection Failed(0) Scheduled by Pol

ling Job 1002.48

5 admin Oct 25 2006 01:09:12 Oct 25 2006 01:09:19 Immediate

5. 2219 Inventory Co

llection Failed(0) Scheduled by Pol

ling Job 1041.46

8 admin Oct 24 2006 12:08:32 Oct 24 2006 12:08:34 Immediate

There are no corresponding entries in IC_Server.log for any of these jobs to indicate any problems.

Anything else I can check?

Cheers

Cisco Employee

Re: Inventory collection not working since upgrade to LMS 2.6

Check to make sure ICServer is running, and also check the ICServer.log (Windows) or daemons.log (Solaris). You may also need to enable InventoryPoller debugging under RME > Admin > System Preferences > Loglevel Settings to see messages in IC_Server.log.

New Member

Re: Inventory collection not working since upgrade to LMS 2.6

Hi,

In the ICServer.log file these 3 errors appears very often:

****************************************

java.lang.NoClassDefFoundError: com/cisco/nm/rmeng/inventory/ics/server/ICSDataBaseCleaner

at com.cisco.nm.rmeng.inventory.ics.server.ICServer.initialize(ICServer.java:134)

at com.cisco.nm.rmeng.inventory.ics.server.ICServer.(ICServer.java:76)

at com.cisco.nm.rmeng.inventory.ics.server.ICServer.main(ICServer.java:314)

*********************************

and also

**********************************

Exception in thread "main" java.lang.NoClassDefFoundError: com/cisco/nm/rmeng/inventory/ics/server/ICSDataBaseCleaner

at com.cisco.nm.rmeng.inventory.ics.server.ICServer.initialize(ICServer.java:134)

at com.cisco.nm.rmeng.inventory.ics.server.ICServer.(ICServer.java:76)

at com.cisco.nm.rmeng.inventory.ics.server.ICServer.main(ICServer.java:314)

***************************

and

**************************

com.cisco.nm.xms.ctm.common.CTMException: URN_NOT_FOUND : urn "EssentialsDM" : Not found !!

at com.cisco.nm.xms.ctm.client.CTMCall.establishIPC(CTMCall.java:201)

at com.cisco.nm.xms.ctm.client.CTMCall.invoke(CTMCall.java:365)

at com.cisco.nm.xms.ctm.client.CTMCall.setMethodAndInvoke(CTMCall.java:412)

at com.cisco.nm.rmeng.inventory.dm.DeviceAccessStatusUpdater.updateDeviceAccessResult(DeviceAccessStatusUpdater.java:63)

at com.cisco.nm.rmeng.inventory.dm.DeviceAccessStatusUpdater.run(DeviceAccessStatusUpdater.java:51)

at com.cisco.nm.rmeng.inventory.dm.threadpool.Thread_Pool$ExecutorThread.run(Thread_Pool.java:154)

********************************

I enabled debugging in the Loglevel settings and tried to manually update the Inventory of two devices and received the following messages:

[ Wed Oct 25 15:01:48 EST 2006 ],INFO ,[main],com.cisco.nm.rmeng.inventory.ics.server.ICServer,403,Updated the cogs jar version

[ Thu Oct 26 12:13:42 EST 2006 ],DEBUG,[ICServer],com.cisco.nm.rmeng.util.logger.RMELogger,734,com.cisco.nm.rmeng.inventory.ics.server.DMgtRunner,run,349,Got Dmgt message and type is :1111708500

[ Thu Oct 26 12:21:29 EST 2006 ],DEBUG,[ICServer],com.cisco.nm.rmeng.util.logger.RMELogger,734,com.cisco.nm.rmeng.inventory.ics.server.DMgtRunner,run,349,Got Dmgt message and type is :1111708500

which do not appear to be errors.

Cisco Employee

Re: Inventory collection not working since upgrade to LMS 2.6

The first two errors point to a missing class file. you should have an NMSROOT/MDC/tomcat/webapps/rme/WEB-INF/classes/com/cisco/nm/rmeng/inventory/ics/server/ICSDataBaseCleaner.class. Since it sounds like you do not, that could point to a bad installation.

The third error indicates that the EssentialsDM daemon may not be running or may not be initialized properly. This may be a result of the same or other missing class files.

At this point, I recommend you open a TAC Service Request. At the very least they can send you the missing class file to see if it helps. At the worst, you will need to reinstall LMS.

406
Views
0
Helpful
6
Replies