Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

IOS not enough memory

I have a 2950IE that I am tring to upgrade the IOS and it is not letting me because I dont have enough memory. I deleted everything from flash and still not enough. I tried to delete the .bin OS but it wont let me. So how do I upgrade this thing if the default os is too big to let another os on to load?

6 REPLIES
Cisco Employee

Re: IOS not enough memory

What is the size of the image you are trying to load? What is the available space?

Community Member

Re: IOS not enough memory

Directory of flash:/

2 -rwx 2888547 Mar 01 1993 00:03:23 c2950-i6q4l2-mz.121-13.EA1.bin

3 -rwx 273 Jan 01 1970 00:01:42 env_vars

4 -rwx 1876 Mar 01 1993 00:23:55 vlan.dat

5 -rwx 5 Mar 01 1993 03:09:55 private-config.text

7 drwx 0 Apr 16 1993 17:28:54 html

21 -rwx 111 Apr 16 1993 21:03:21 info

22 -rwx 109 Mar 01 1993 00:04:20 info.ver

23 -rwx 3269 Mar 01 1993 03:09:55 config.text

24 -rwx 1793 Mar 01 1993 02:50:27 y

7741440 bytes total (4841472 bytes free)

I deleted all the html files to free up space.

Re: IOS not enough memory

HI

What is the size of IOS you are trying to load?

Regards

JD

Community Member

Re: IOS not enough memory

Can you be more specific about why it won't let you delete the IOS.bin file?

Is there an ximages directory in the html directory?

drwx 2432 Mar 01 1993 00:05:00 ximages

If so, you must delete all those files and remove the directory.

rmdir flash:html/ximages

Then remove the html directory.

Not 100% sure, you may need to delete the info file.

erase flash:info

Then delete the IOS.bin file.

erase flash:c2950-i6q4l2-mz.121-13.EA1.bin

Also, copy & paste the IOS.bin file name, don't type it in.

Proceed with upgrade.

Community Member

Re: IOS not enough memory

I tried to do it through the CNA also and this is what it listed.

Determining total flash size.

Extracting the info file from the tar image.

Reading the info file of the tar image.

Actual free space 4841472

Required Space 5541888

Software upgrade failed.

There is insufficient flash space for the new image.

Total free space required is 5541888 bytes

Remove unwanted files from the flash and upgrade again.

I deleted ALL the files in the html folder.

Community Member

Re: IOS not enough memory

You did not go through my list. It's possible to delete all the html files and still have files in an ximages folder. This may or may not be the case, ximages folder does not always exist.

What about deleting the old IOS.bin file? Sometimes thats what you have to do! Word of caution though, be sure the new IOS will work on that switch! If it doesn't your switch is down and you'll have to transfer a compatible IOS via xmodem (S-L-O-W). So be sure you tftp that old IOS.bin file first before deleting it.

968
Views
0
Helpful
6
Replies
CreatePlease to create content