Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IPM 2.6.0 Database not starting problems

Hi,

We have been having problems with our IPM application not starting.

We run it, along with the other LMS 2.6 applications on Windows 2003 servers.

I recently removed and reinstalled it, and everything worked. The support people installed the latest patches on the server, and since then it wont restart. The DFM application has started ok.

Part of the instructions given to the suuport people was to stop the IPM processes before they started installing any patches, and it looks like they have done this.

I have tried cleaning out the DB (as I have nothing in it), but when I do the ipm dbclean command, I get the following:

VisiBroker: Unable to locate agent. Will try every 15 seconds to locate agent

DSUser:: Unable to contact agent. Make sure there is an agent running on this network

IPM Process Manager Already Stopped.

IPM Aging Server Already Stopped.

IPM Database Server Already Stopped.

IPM Naming Server Already Stopped.

Forcefully stopping all IPM Processes

Removing IPM Database Log File...

-- IPM Database Log Removed.

Copying IPM Database into place...

-- IPM Database Copy Failed.

There was a problem with the cleaning processs

D:\Internetwork Performance Monitor\Server\bin>

D:\Internetwork Performance Monitor\Server\bin>

I really would like to understand what is going on here. I didnt have these problems restarting it just after the install.

A couple of other points that may have an impact:

1) Server has multiple NIC's

2) It runs in Slave mode, with the master DB on another server.

Reinstalling the software is a mission because of the change control process we have to go through if we come anywhere near having to restart the server (political, not technical)

Any ideas greatly appreciated

Jeff

2 REPLIES
Cisco Employee

Re: IPM 2.6.0 Database not starting problems

In order for the database reinitialization process to work, the IPM processes must be down. Try setting all of the IPM services to Manual, then reboot the server, then try to run "ipm dbclean". If you still get an error copying the database, check the IPM\Server\Sybase directory to see that you have an IPMDB_ini.db file, and check the no other process is using the IPMDB.db file (you will need Process Explorer from http://www.sysinternals.com for this).

Once you are able to reinitialize the database, reset the IPM services to Automatic, then reboot again. From there, further debugging information can be captured if problems remain.

New Member

Re: IPM 2.6.0 Database not starting problems

Changed the services to be manual, restarted the server, and ran the ipm dbclean command again. Exactly the same results.

Removed and reinstalled the IPM application and it all works again.

I have gone through the process of stopping the IPM services and restarting the server twice, and both of these times everything restarted as expected.

I dont know what to do now, apart from keeping my fingers and toes crossed.

We are starting to work on the business case for upgrading to LMS 3.0, which contains the new IPM version amongst other things. Perhaps the problems we have had with this version will help us get it approved.

Thanks for your help.

144
Views
0
Helpful
2
Replies