Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IPM 2.6 no Reports available

hello, running IPM 2.6.0.0 Everything looks good except the Reports. On all report types no available reports show. The window is blank for all report types

In the Process Status seems OK, all states show ready and/or running

How do I troubleshoot this? Is there a relevant section in the "Troubleshooting Info"? thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: IPM 2.6 no Reports available

Check C:\progra~1\CSCOpx\bin. Do you have a perl directory here? If so, delete it, and this problem should go away.

13 REPLIES
Cisco Employee

Re: IPM 2.6 no Reports available

Pick one of your Collectors, and check to make sure it is still running, and running successfully. This may mean going to the source device, and running "show rtr collection-sta", "show rtr config", "show rtr oper" (note: depending on the server of IOS, this may be "show ip sla" or "show ip sla monitor").

Assuming the collectors are still running successfully, check to make sure IPM can communicate with them. Use the CiscoWorks Device Center to SNMP walk the devices starting at .1.3.6.1.4.1.9.9.42.

Finally, the ipmLogger.log.X may have some relevant errors as to why report data cannot be collected or displayed.

New Member

Re: IPM 2.6 no Reports available

With regard to the collectors themselves everything looks good.

rtr/ip sla on the devices is working stats updating and traps being sent.

Also within the IPM client everything looks healthy - config stats history etc. Just the Reports that are empty

To me it looks like data is being collected just that there are no reports in the pane to select and action - the pane is completely blank.

Will check ipmLogger.log.X for anything obvious. thanks

Cisco Employee

Re: IPM 2.6 no Reports available

We maybe talking about two separate things. Please post a screenshot illustrating your problem. Also, on what platform are you running IPM?

New Member

Re: IPM 2.6 no Reports available

Running on W2k

All report types i.e. Configuration, Latency, Jitter etc and all their sub-types display a blank pane as shown attached

New Member

Re: IPM 2.6 no Reports available

Sorry that should say running on win2003

Cisco Employee

Re: IPM 2.6 no Reports available

Please post the NMSROOT\MDC\tomcat\logs\stdout.log as well as the output of "ipm export -c" run from within the IPM DOS command prompt.

New Member

Re: IPM 2.6 no Reports available

I kinda suspected the web app area but didn't know where to look; now I know, thanks!

See attached for tomcat stdout and ipm export -c

To my untrained eye these lines look interesting in the Tomcat stdout

action: Looking for Action instance for class com.cisco.nm.uii.forwardToScreenID

action: UIIController processActionForward does not have a screenID so no authorization was done for /WEB-INF/screens/ipm/ipmCgiOutput.jsp.

Cisco Employee

Re: IPM 2.6 no Reports available

Nothing wrong here, either. Try running this command from the IPM DOS prompt:

perl C:\PROGRA~1\INTERN~2\Server\bin\nph-ipmReports.pl collector

What output do you get?

New Member

Re: IPM 2.6 no Reports available

The html output looks good, all the collectors are there each with links to the doAction Javascript function e.g.

javascript:doAction('collectors','daily_jitterstats','0','2147483647','cus1s-ndc1s-G711','2');"

I thought we were onto something before with the Tomcat msesages about no authorization for UIIController against ipmCgiOutput.jsp ?

Cisco Employee

Re: IPM 2.6 no Reports available

Those messages are normal, and do not indicate an error. It sounds like everything should be working. The last bit of server-sided debugging that can be done is to run "ipm debug" from the IPM DOS shell, enable IPMProcessManager debug and trace, then reproduce the problem. Then post the ipmLogger.log files.

On the client side, there could be a Javascript error triggering a problem. In one of the browser's URL fields, type in "javascript:" and hit enter. The resulting Javascript console may contain errors that could point to the problem.

New Member

Re: IPM 2.6 no Reports available

Problem is reproduceable across many different clients/browsers/java so leads me to think it's not client side?

IPMProcessManager and ipmLogger.log debug output attached. At the 17:46:19 timestamp I clicked on "Configuration Reports > Collectors"

While attempting to exec nph-ipmReports.pl is it throwing an exception for CreateProcess ?

Cisco Employee

Re: IPM 2.6 no Reports available

Check C:\progra~1\CSCOpx\bin. Do you have a perl directory here? If so, delete it, and this problem should go away.

New Member

Re: IPM 2.6 no Reports available

Success! It wasn't a dir but an empty file named "perl". Renamed it and all OK. Bit of a mystery, timestamp from months ago. Will delete it.

Thanks so much for your patient assistance. I've learned a lot about troubleshooting IPM at least.

189
Views
0
Helpful
13
Replies