Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Just installed LMS 2.6 cannot login - 500 Internal Server Error ?

I did a brand new clean install of 2.5 from CD then to 2.5.1 using the downloaded patch, then 2.6 using the downloaded patch, no errors.

When try to login I get the following errors.

HTTP Status 500 - Internal Server Error

Any ideas guys ?

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Just installed LMS 2.6 cannot login - 500 Internal Server Er

The move data error points to files being locked by running processes. The best way around this is set the CiscoWorks Daemon Management and all IPM services to Manual in the Services Control Panel, then reboot.

Since your install is in an unknown state, I'd start from scratch again. When applying the 2.5.1 and 2.6 updates, keep those services set to Manual.

Once everything is installed, then set just the CiscoWorks Daemon Management and IPM services back to Automatic, then reboot once again.

9 REPLIES
Cisco Employee

Re: Just installed LMS 2.6 cannot login - 500 Internal Server Er

Something is wrong with your NMSROOT/MDC/tomcat/shared/lib/jdom.jar file. This file should be 153253 bytes under LMS 2.6, but I'm guessing yours is not.

This problem is usually indicative of a bad installation somewhere along the line. The most common cause if this is Windows, is a TEMP/TMP directory that uses long filenames. When we see these kinds of errors, we reset TEMP and TMP to C:\TEMP, and re-do a clean installation.

Alternatively, if your jdom.jar file is the right size, it may be corrupt, or you may have a jdom directory somewhere under NMSROOT. If the latter, remove this directory, and you should be fine. If the former, again, this points to a bad installation.

New Member

Re: Just installed LMS 2.6 cannot login - 500 Internal Server Er

my jdom.jar file is 126,976 bytes.

So it looks like you are correct.

I can start again from scratch but how do I check my TEMP and TMP directories and ensure they are set correctly ?

Thanks

D

New Member

Re: Just installed LMS 2.6 cannot login - 500 Internal Server Er

okay I had one of my Windows admins change environment variables for tmp and temp to c:\tmp and c:\temp. I'm deleting Ciscoworks and trying to reinstall now.

Thanks

D

New Member

Re: Just installed LMS 2.6 cannot login - 500 Internal Server Er

So I have got to installing the LMS_2_5_DEC05 updates and after a while I get this error (which I did see last time, but plowed on anyway)

Installing Ciscoworks Process Management 47%

An error occured during the move data process: -105

component: pm

file group:

file:

I hit okay and the installation drops back to desktop.

What could this latest error be ?

Should I try installing the 2.6 patch anyway ?

D

New Member

Re: Just installed LMS 2.6 cannot login - 500 Internal Server Er

Just finished installing 2.6 again, same problem. This is not good. I have until Friday to finish this project.

Arrgh

Cisco Employee

Re: Just installed LMS 2.6 cannot login - 500 Internal Server Er

Which problem? The move data problem, or the original problem? If the latter, what did you do to overcome the move data problem? If you just went ahead and installed 2.6, your installation is once again corrupt.

New Member

Re: Just installed LMS 2.6 cannot login - 500 Internal Server Er

The move data problem occured again. Thought I'd try installing 2.6 again with the new c:\tmp and c:\temp env variables defined, thought maybe it would work because logging in after the 2.5.1 install (even with the move data error) worked.

Cisco Employee

Re: Just installed LMS 2.6 cannot login - 500 Internal Server Er

The move data error points to files being locked by running processes. The best way around this is set the CiscoWorks Daemon Management and all IPM services to Manual in the Services Control Panel, then reboot.

Since your install is in an unknown state, I'd start from scratch again. When applying the 2.5.1 and 2.6 updates, keep those services set to Manual.

Once everything is installed, then set just the CiscoWorks Daemon Management and IPM services back to Automatic, then reboot once again.

New Member

Re: Just installed LMS 2.6 cannot login - 500 Internal Server Er

Thanks for your help jclarke.

I have 2.6 running now.

IIS was installed on the machine but disabled.

I deleted it.

IBM Director was installed, I deleted it because I remember having problems with Ciscoworks and IBM director in the past.

I performed your suggestions above as well.

Thanks again.

D

187
Views
5
Helpful
9
Replies
CreatePlease login to create content