Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

LMS 2.2 SNMP strings not taking to discover devices

HI all,

Can anybody help me? I am running LMS 2.2 I have configured SNMP strings (only RO). But the devices are not discovered properly. It discovered the devices but saying unknown & unreachable. That means its not taking SNMP to descover devices. Only through CDP it is discovering. In cisco view when I am trying to see the devices if I give SNMP RO individualy its working. When I am trying to check connectivity through SNMP also its not working unless I give the SNMP string separatly.

I am uploading some errors. Pls have a look & help me out.

odbc.pl

FAIL

C:\WINNT\system32\odbccp32.dll FileVersion : 3.520.6307.0

C:\WINNT\system32\odbccp32.cpl FileVersion : 3.520.6200.0

C:\WINNT\system32\odbcad32.exe FileVersion : 3.520.6200.0

C:\WINNT\system32\odbccr32.dll FileVersion : 3.520.6200.0

C:\WINNT\system32\odbc32.dll FileVersion : 3.520.6307.0

C:\WINNT\system32\odbcint.dll FileVersion : 3.520.6200.0

go to top

--------------------------------------------------------------------------------

platform.pl

PASS supported platform : 'ServerNT'

go to top

--------------------------------------------------------------------------------

snmp.pl

FAIL Found d:\cscopx\campus\bin\CWSNMP.DLL

Found d:\cscopx\campus\bin\CWSNMP.DLL

Thanks in advance

Sachi

7 REPLIES
Cisco Employee

Re: LMS 2.2 SNMP strings not taking to discover devices

You will need to post your NMSROOT\campus\etc\cwsi\anisnmp.conf file, but this will contain your SNMP communities, so it might be better if you open a TAC service request with this information.

Re: LMS 2.2 SNMP strings not taking to discover devices

Hi JC,

Thanks for your response. When I am saving the SNMP strings it saves in the anisnmp.conf file but the syntax starts with two hash signs.I beleive that means the SNMP string did not accepted by ANI Server.

Even if I delete those two hash signs also its not working.

I opened the anisnmp.conf.orig file to see the exact syntax.

I didnt configure write string correctly as per customer request. Do you think this may making the problem.

Can you pls advise?

Thanks in advance

Sachi

Cisco Employee

Re: LMS 2.2 SNMP strings not taking to discover devices

Discovery only requires SNMP read-only community strings. Read-write strings are simply nice to have. You cannot modify this file manually unless ANIServer and JRunProxyServer are down. You should be adding community strings via Server Configuration > Setup > ANI Server Admin > SNMP Settings.

Re: LMS 2.2 SNMP strings not taking to discover devices

Yes I am adding through server configuration>aniserver admin>snmp settings only but the mistake I did is I opened the anisnmp.conf file in notepad to see the contents. By mistake I opened it with always open in notepad checked.Earlier it was a sav file.

Even I reinstalled everything still the same issue. shall I stop crmdmgtd & then modify the the anisnmp.conf file syntax.

Thanks again

sachi

Cisco Employee

Re: LMS 2.2 SNMP strings not taking to discover devices

Given that LMS 2.2 will no longer be supported this coming Tuesday, I suggest you open a TAC service request now, and have them look at this. I do not have the time to do log file analysis as I am at Cisco Live.

Re: LMS 2.2 SNMP strings not taking to discover devices

Thanks for advise

I will do that.

Re: LMS 2.2 SNMP strings not taking to discover devices

Hi JC,

The TAC is not responding & time is running out. Can you pls help me out of this. I just need to discover the devices nothing else.

Even though the devices discovered are showing UNknown & Unreachable..

When I am trying to see ciscoview it asks for SNMP string again & after entering the SNMP string I am able to reach the device & see the view.

Thanks in advance

Sachi

147
Views
0
Helpful
7
Replies
CreatePlease to create content