Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

LMS 2.5.1 RMEDbEngine failed to Start

I am not sure if anyone has run into this, but I stopped all my services and then restarted them and the REMDb will not start back up. I am running LMS 2.5.1 on Solaris. I have TAC looking at this but they are suggesting re-install and I really dont want to do that. This is a production box and I really dont want it all down for the day (DFM and Ciscoview work perfectly).

Any suggestions?

4 REPLIES
Cisco Employee

Re: LMS 2.5.1 RMEDbEngine failed to Start

Shutdown dmgtd, then look into /opt/CSCOpx/databases/rmeng, and see if you have an rmeng.log file in there. If you do, remove it, then do the following as root:

# csh

# setenv LD_LIBRARY_PATH /opt/CSCOpx/lib:/opt/CSCOpx/objects/db/lib

# setenv PATH ${PATH}:/opt/CSCOpx/objects/db/bin

# setenv SATMP /var/adm/CSCOpx/files/.SQLAnywhere

# setenv ASANY /opt/CSCOpx/objects/db

# cd /opt/CSCOpx/databases/rmeng

# dbsrv9 -f rmeng.db

This will force a rollback on all pending transactions, and set the database to a "quiet" state. At this point, you should be able to start dmgtd, and have the database come up.

If the transaction log didn't exist, or RMEDbEngine still does not start, you can try reinitializing the RME database:

/opt/CSCOpx/bin/dbRestoreOrig.pl dsn=rmeng dmprefix=RME

If that does not work, a reinstall may be necessary.

Community Member

Re: LMS 2.5.1 RMEDbEngine failed to Start

Thanks, Steps sent corrected ANI and RME datbase, engine and log issues. System backup and working..

Community Member

Re: LMS 2.5.1 RMEDbEngine failed to Start

Hi

I have similar problem

My LMS 2.5 ANIServer can not start due to

"Administrator has shut down this server" message , Why

1. AdapterServer Never started 0 0 0 N/A Not applicable

2. ANIDbEngine Program started - No mgt msgs received 23806 0 0 06/20/07 17:57:26 Not applicable

3. ANIServer Administrator has shut down this server 0 -2 0 06/20/07 18:29:06 06/20/07 18:29:08

4. CampusOGSServer Never started 0 0 0 N/A Not applicable

5. ChangeAudit Never started 0 0 0 N/A Not applicable

6. CmfDbEngine Program started - No mgt msgs received 23769 0 0 06/20/07 17:55:01 Not applicable

7. CmfDbMonitor Administrator has shut down this server 0 -11 0 06/20/07 18:26:57 06/20/07 18:26:57

8. CMFOGSServer Never started 0 0 0 N/A Not applicable

9. ConfigMgmtServer Never started 0 0 0 N/A Not applicable

10. CSRegistryServer Running normally 23808 0 0 06/20/07 17:57:34 Not applicable

Cisco Employee

Re: LMS 2.5.1 RMEDbEngine failed to Start

This is a completely different issue, and may not be database related. Please start a new thread for this problem.

234
Views
5
Helpful
4
Replies
CreatePlease to create content