Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

LMS 2.6-Campus Manager Not Collecting All Device Data

Under CM--Home--System Status, I have 33 devices with Data Collection and 59 devices with Device Discovery. What would be the primary cause for this discrepency? All seed devices have been entered and SNMP strings appear to be fine.

6 REPLIES
Cisco Employee

Re: LMS 2.6-Campus Manager Not Collecting All Device Data

The most likely cause of this discrepancy is that not all of the 59 discovered devices were reachable. Device Discovery will only send reachable devices into DCR, and thus to be managed by applications like Campus Manager (i.e. Data Collection). Another cause is Data Collection filters that prevent devices from being managed by Campus.

Re: LMS 2.6-Campus Manager Not Collecting All Device Data

I summerized a step-by-step procedure to look for possible issues in this thread - perhaps it helps you...

http://forums.cisco.com/eforum/servlet/NetProf?page=netprof&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40.1dddb1b3/16#selected_message

New Member

Re: LMS 2.6-Campus Manager Not Collecting All Device Data

Thanks for the information. The snmp checks out fine on devices showing unreachable and access is allowed between server and device. The number is now 37 with Data Collection and 62 with Device Discovery. Could TACACS+ credentials pose a problem in this scenario?

Cisco Employee

Re: LMS 2.6-Campus Manager Not Collecting All Device Data

ACS integration would not account for devices showing up as unreachable. What did you do to verify that the SNMP credentials are correct?

New Member

Re: LMS 2.6-Campus Manager Not Collecting All Device Data

Simply comparing the strings on the devices and what's entered in CW. Everything is the same.

Cisco Employee

Re: LMS 2.6-Campus Manager Not Collecting All Device Data

Then there may be ACLs or firewalls between CiscoWorks and the device. Try using the SNMP Walk tool built into the LMS Device Center to walk the device starting from system. If this does not work, you should try enabling "debug snmp packet" on the device to see if the SNMP requests are making it. If they are not, then you will have to go hop-by-hop in the path between LMS server and device to see where the packets are being dropped.

228
Views
7
Helpful
6
Replies
CreatePlease to create content