Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

LMS 2.6 config archive failed

We have LMS 2.6 on Windows platform, problem is with few devices where config archive is failed.

There is no integration with ACS. Credentials (SNMP Read and WRITE, Telnet Username and Password) are OK.

When trying to collect configurations Error messages are: see Error1

 

We configured timeout on bigger value and error message is: see Error2

 

 

On device that we tried to collect config we configured debug aaa authentication, but nothing was happening.

 

We deleted devices from RME and also from Common Services and readded them, but problem was still there.

 

There is attachment dcmaservice.log when trying config archive for two devices:

 

Successful job      Mar 02 2010 12:59:31 for device   10.64.11.121

Unsuccessful job    Mar 02 2010 12:38:56 for device   10.64.11.113

 

 

 

 

 

 

 

6 REPLIES
Cisco Employee

Re: LMS 2.6 config archive failed

I'm seeing what appears to be a timeout for 10.64.11.113.  You have a 40 second telnet timeout set, but this appears to be too short.  After RME telnets to the device, it seems to be taking longer than 40 seconds to get the login prompt.  Try increasing your telnet timeout in RME to match how long it takes to get the login prompt.

Community Member

Re: LMS 2.6 config archive failed

I didn't mention couple of things:

When we connect to CiscoWorks using Remote Desktop application, we can telnet to mentioned device instantly,  and as soon I start telnet session I get username prompt, as soon I press return after entering username and pasword, I got logged in.

We use ACS for authenticating CW when trying to telnet to device. For all devices it works fine, only for three of them there is a problem. There is no differince in configurations between those devices which works ok and other ones.

We will change timeout first thing in the morning.

Cisco Employee

Re: LMS 2.6 config archive failed

You could also get a sniffer trace of all telnet traffic to these devices when running the sync archive job.  That would clearly show how much time is being required at each step of the login.

Community Member

Re: LMS 2.6 config archive failed

There are messages before and after changing timeouts in file Troublesh 15.3.rtf.

We checked Device Credentials and realized that only CiscoWorks can access devices that uses SSH, but can NOT access devices that are using Telnet (it was 16.2.2010 when last telnet authentication was ok). When telneting from Command prompt on CW server everything is ok. You can find output of debug aaa authentification from one device in file       Troublesh 15.3.rtf.

We have also captured traffic on CW server with wireshark, filtered telnet traffic and after that selected Follow tcp stream for that telnet session.

It seems that CW is not entering Telnet credentials when prompted for them, so username request times out... while on the SAME device when using SSH CW woks fine.

Cisco Employee

Re: LMS 2.6 config archive failed

Without seeing the binary sniffer trace myself, I cannot comment further.  If you cannot share this information, open a TAC service request, and provide them with the sniffer trace.

Community Member

Re: LMS 2.6 config archive failed

Hello Joe,

first, many thanks for your support.

It seems that we solved our problem.

It was connected with migrating from ACS 4.x to 5.x. which we used for AAA for CiscoWorks (it is in Tacacs mode) and network devices.

Cisco Works did not send any credentials at all, because new ACS sent by default prompt, which CiscoWorks did not understand:

username:

password:

Resolution of the problem was to change prompt that ACS sends to CW to following

Username:

Password:

Best regards,

Savo.

631
Views
0
Helpful
6
Replies
CreatePlease to create content