Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

LMS 2.6 database restore problem

I had a crash of my Windows2003 server running LMS 2.6. We managed to restore the OS, LMS application, etc. I try running the restorebackup.pl script, but get an error saying the database password has changed. Is there a way to get around this, or just create empty databases (for all installed applications) and start from scratch?

Thanks!

6 REPLIES
Cisco Employee

Re: LMS 2.6 database restore problem

You can first try resetting the database's password using the NMSROOT\bin\dbpasswd.pl script (NMSROOT\bin\perl NMSROOT\bin\dbpasswd.pl). If that doesn't work, then you can reinitialize the database using the NMSROOT\bin\dbRestoreOrig.pl command.

New Member

Re: LMS 2.6 database restore problem

Unfortunately neither of those work, as the odbc.tmpl files are missing. These were missed in the backup by the application, or by the sysadmin.

Cisco Employee

Re: LMS 2.6 database restore problem

Ouch, that should not happen. The odbc.tmpl files should be backed up to REV/APP/APP.tmpl (e.g. 0/cmf/cmf.tmpl). If that does not happen, you should at least be able to reinitialize the database using dbRestoreOrig.pl provided the original database file and odbc.tmplorig exist.

New Member

Re: LMS 2.6 database restore problem

I have no "odbc".tmplorig files anywhere. Is there a way to copy the "odbc".tmpl files and modify them to act as the original? I can copy a version of the .db file from the backup directory.

Cisco Employee

Re: LMS 2.6 database restore problem

At this point, I don't think you can trust the application data that was backed up by your sysadmin. It might be safer to completely uninstall LMS, then reinstall and re-patch it. Once it is back to the current patch rev, then you can restore the LMS backup that was taken.

New Member

Re: LMS 2.6 database restore problem

That's what I was suspecting. At least I'll make sure to grab a copy of my .lic file. Thanks for the try!

175
Views
0
Helpful
6
Replies