Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

LMS 2.6 will not discover new device

Trying to add an Cisco Catalyst 2960-48TC-L to CiscoWorks. Our tech has updated this device with IOS Ver 12.2 (46)SE. Would this have impact on discovery?

6 REPLIES
Cisco Employee

Re: LMS 2.6 will not discover new device

No, this version is fine. How are you trying to add this device to LMS? Are you hoping for Discovery to pick this up, or are you trying to add it to DCR manually? Your post is a bit confusing as to which.

If Discovery, what error or what status do you get for this device? What version of Campus Manager?

New Member

Re: LMS 2.6 will not discover new device

Thank you for the reply. This device was added manually, and shows in the topology map as red with ?. Campus Manager is 4.0.12. A bit confusing to me as well. Two other similar devices show up fine in the map. Device Center is displaying correct type, and IP address. I also noticed that the Syslog message summary is populated with messages. I can telnet, and traceroute. I had hoped it may have something to do with the IOS. Discovery status shows Questioned but no discovery.

Cisco Employee

Re: LMS 2.6 will not discover new device

Hmmm, this points to an SNMP reachability issue. Double-check the SNMP credentials in DCR for this device, and make sure they are correct. Try running an SNMP Walk to this device from Device Center. Use a starting OID of "sysObjectID".

New Member

Re: LMS 2.6 will not discover new device

Nope, the SNMP Walk keeps failing for the device. I have checked the Community String, and such but still it fails.

Cisco Employee

Re: LMS 2.6 will not discover new device

I have a feeling you might be seeing CSCsv37696, then. The fix is in 12.2(50)SE. Does this sound valid:

Symptom:

This is very easy to reproduce.

Basically, once interface fa0 is assigned a DHCP address with a reload, even ICMP packets

are still going through ok, no SNMP queries are being processed by the device.

Conditions:

This is only an issue for 12.2(46)SE. Older versions are not affected.

Workaround:

Assign the DHCP address to a VLAN interface or to a layer 3 interface such as gig0/1 with:

interface gig0/1

no switchport

ip address dhcp

New Member

Re: LMS 2.6 will not discover new device

Issue has been resolved. Technician restored IOS to previous version before (46)SE and this resolved the issue. Tech did not have access to (50)SE. Once switch was restarted with IOS, it identified.

136
Views
5
Helpful
6
Replies
CreatePlease to create content