Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

LMS 3.1 ~ 3.2 upgrade, backup fails on sql

I keep getting an error on the backup when installing. Says problem with field X in form Y on the local SQL database.

Any thoughts? I am trying again.

4 REPLIES
Cisco Employee

Re: LMS 3.1 ~ 3.2 upgrade, backup fails on sql

Post the entire output as well as the dbbackup.log. It sounds like perhaps one of the databases is corrupt.

New Member

Re: LMS 3.1 ~ 3.2 upgrade, backup fails on sql

Thanks Joe,

In looking at the error message info on the upgrade docs it just says to try again.

I am waiting on the fail and will send over.

However,

Yes original media from Cisco.

Local update, non High Availiblity mode. Am waiting for fail then will send uyou info.

New Member

Re: LMS 3.1 ~ 3.2 upgrade, backup fails on sql

Error message:

Backup operation failed. Please look at

for the reason for failure.

Click Retry to take backup again

Click Exit to exit the application

From the bottom of the log file,,,,

VALIDATE TABLE "SYS"."ISYSUSERMESSAGE"

VALIDATE TABLE "SYS"."ISYSUSERTYPE"

VALIDATE TABLE "SYS"."ISYSVIEW"

VALIDATE TABLE "SYS"."ISYSWEBSERVICE"

1 error reported

SQL error (-300) -- Run time SQL error -- Validation of table "NOS_NEW_DeviceDetailTable" has failed

[Mon Aug 31 16:55:48 2009] Validation D:/LMS32U~1/AUTOMA~1/CMFBAC~1\0\dfm\database\dfmInv.db failed.

[Mon Aug 31 16:55:48 2009] Validation D:/LMS32U~1/AUTOMA~1/CMFBAC~1\0\dfm\database\dfmInv.db failed.

[Mon Aug 31 16:55:48 2009] ERROR(1101): Database dfmInvDb backup failed and . Check the log file for information.

[Mon Aug 31 16:55:48 2009] Backup failed: 2009/08/31 16:55:48

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Cisco Employee

Re: LMS 3.1 ~ 3.2 upgrade, backup fails on sql

This is a known issue with the dfmInv database, and it has been corrected in LMS 3.2. If you have a known good backup of 3.1, simply re-run the 3.2 setup.exe as:

setup.exe nobackup

Then, after installing LMS 3.2, restore your 3.1 backup if necessary. Else, you will need to reinitialize the dfmInv database, then perform the 3.2 installation.

To reinitialize the dfmInv database, run:

NMSROOT/bin/perl NMSROOT/bin/dbRestoreOrig.pl dsn=dfmInv dmprefix=INV

209
Views
0
Helpful
4
Replies