Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

LMS 3.1 can't collect inventory from 6506-E

Hello,

We have a bunch of 6506E and 6509E all managed by LMS, but our two new ones (6506-E) are giving LMS some trouble. Their config is successfully archived, but their inventory is not collected (Job status : Device Collection Failed). It doesn't _seem_ to be an SNMP timeout issue AFAIK.

I've attached the (hopefully) relevant portion of IC_Server.log.

Thanks for the help!

2 ACCEPTED SOLUTIONS

Accepted Solutions
Cisco Employee

Re: LMS 3.1 can't collect inventory from 6506-E

This is CSCsx58694. A patch for RME 4.2 is available from TAC while the bug is fixed in LMS 3.2. The recommended solution is to upgrade to LMS 3.2.

Cisco Employee

Re: LMS 3.1 can't collect inventory from 6506-E

Bumping the Campus timeout has no effect on RME.  Go to RME > Devices > Device Management > RME Devices, and edit the device attributes for this switch.  Enter an SNMP timeout value of 10, then save the changes, and be sure to apply them on the previous screen.  Inventory collection should work then.

10 REPLIES
New Member

Re: LMS 3.1 can't collect inventory from 6506-E

Here is the attachment, as the form didn't let me upload it at time of posting.

Cisco Employee

Re: LMS 3.1 can't collect inventory from 6506-E

What version of code is this switch running? What version of RME?

New Member

Re: LMS 3.1 can't collect inventory from 6506-E

Cisco IOS Software, s72033_rp Software (s72033_rp-IPSERVICESK9-VM), Version 12.2(33)SXI2a, RELEASE SOFTWARE (fc2)

System image file is "sup-bootflash:s72033-ipservicesk9-vz.122-33.SXI2a.bin"

RME 4.2.0

Cisco Employee

Re: LMS 3.1 can't collect inventory from 6506-E

This is CSCsx58694. A patch for RME 4.2 is available from TAC while the bug is fixed in LMS 3.2. The recommended solution is to upgrade to LMS 3.2.

New Member

Re: LMS 3.1 can't collect inventory from 6506-E

Allright, now I've got a reason to push LMS 3.2 in!

Joe, you are the man!

Assuming 3.2 is a free upgrade from 3.1, can I download it from Cisco.com or must I order it from our usual sales rep ?

Thanks a bunch, and a good weekend to you!

Cisco Employee

Re: LMS 3.1 can't collect inventory from 6506-E

You can do both. You can enter your LMS 3.0 SAS contract number into http://www.cisco.com/upgrade/ to request the DVD kit, or you can download the LMS 3.2 eval from http://www.cisco.com/go/lms/ . If you install the eval over a licensed 3.1, you will get a licensed 3.2.

New Member

Re: LMS 3.1 can't collect inventory from 6506-E

I've just upgraded to LMS 3.2, and LMS still can't inventory my two 6506-E.

I've run an "SNMP Walk" against one device, and it seems to work : here's the first few lines of it :

****

The following is a SNMP walk of device 10.x.x.x starting from

SNMP Walk Output
--------------------------------------------------------------------------------


RFC1213-MIB::sysDescr.0 = STRING: "Cisco IOS Software, s72033_rp Software (s72033_rp-IPSERVICESK9-VM), Version 12.2(33)SXI2a, RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2009 by Cisco Systems, Inc.

Compiled Tue 01-Sep-09 22:55 by prod_re"
RFC1213-MIB::sysObjectID.0 = OID: CISCO-PRODUCTS-MIB::cat6506
EXPRESSION-MIB::sysUpTimeInstance = Timeticks: (803850159) 93 days, 0:55:01.59

****

And I checked the IC_Server.log... this time it mentions SNMP timeout... I tried bumping the timeout to 20 seconds with 2 retries in Campus Manager.

I've attached my IC_Server.log excerpt.

Thanks for the help!

Alex.

Cisco Employee

Re: LMS 3.1 can't collect inventory from 6506-E

Bumping the Campus timeout has no effect on RME.  Go to RME > Devices > Device Management > RME Devices, and edit the device attributes for this switch.  Enter an SNMP timeout value of 10, then save the changes, and be sure to apply them on the previous screen.  Inventory collection should work then.

New Member

Re: LMS 3.1 can't collect inventory from 6506-E

It works now, thanks Joe!

Is it possible to set the snmp timeout globally to 10, and if so, is it a good idea to do so ?

Thanks!

Alex.

Cisco Employee

Re: LMS 3.1 can't collect inventory from 6506-E

Yes, you can do this under RME > Admin > System Preferences > RME Device Attributes.  However, this will not affect devices whose attributes have been updated individually.  I would also caution against raising the SNMP timeout so high for all devices.  It could cause jobs to run longer than they should if unreachable or pre-deployed devices are encountered.

618
Views
0
Helpful
10
Replies