Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Blue

LMS 3.1 CM 5.1.1: UT export error "native2ascii: not found"

When trying to export the UT endhosts data in CSV from the GUI, a "native2ascii: not found" error is returned.

The CLI export apparently works. It still spits out the "native2ascii" error however:

/opt/CSCOpx/campus/bin/ut -cli -query all -export /path/to/ut.txt -layout all -u admin -p admin-password

orbProperties={org.omg.CORBA.ORBInitialPort=42342, org.omg.CORBA.ORBClass=org.jacorb.orb.ORB, org.omg.CORBA.ORBInitialHost=pssva030, org.omg.CORBA.ORBSingletonClass=org.jacorb.orb.ORBSingleton, jacorb.implname=CSEDSPersistentIOR, org.omg.PortableInterceptor.ORBInitializerClass.bidir_init=org.jacorb.orb.giop.BiDirConnectionInitializer}

_Orb=org.jacorb.orb.ORB@13ad085

log4j:ERROR No appenders could be found for category (com.cisco.nm.ani.clients.utng.application.UTDataManager).

log4j:ERROR Please initialize the log4j system properly.

ERROR UTCLI: Error loading preferences. Cannot run program "native2ascii": error=2, No such file or directory

Nothing unusual in Cmapps.log (apparently with debug on, to my surprise again).

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: LMS 3.1 CM 5.1.1: UT export error "native2ascii: not found"

I've filed a bug for this, CSCsw20310. Essentially, you need the JDK included with Solaris to be installed.

15 REPLIES
Cisco Employee

Re: LMS 3.1 CM 5.1.1: UT export error "native2ascii: not found"

native2ascii is a tool installed by Java on Solaris. By default, a full Solaris 9 or 10 installation will include /usr/java/bin/native2ascii which is then symlinked to /bin/native2ascii. If you did not install Java with Solaris, you can copy native2ascii from another machine into /bin, or simply find a dos2unix tool on the Internet (i.e. a tool that converts DOS line endings to UNIX line endings), name this executable native2ascii, and place it in /bin.

Blue

Re: LMS 3.1 CM 5.1.1: UT export error "native2ascii: not found"

Is this a dependency required by LMS/CM UT? It's rather ambiguous that its absence is currently preventing the browser GUI from exporting the UT data, while CLI export is fine. The latter route is not an option for most end-users, nor desirable from the administrative standpoint.

Cisco Employee

Re: LMS 3.1 CM 5.1.1: UT export error "native2ascii: not found"

It is a dependency required by utcli on Solaris. We recommend people install the SUNWCall cluster which includes this executable.

Blue

Re: LMS 3.1 CM 5.1.1: UT export error "native2ascii: not found"

Would a dummy (empty) native2ascii make the GUI export successfully, the error message notwithstanding? I suppose there's a reason this binary or the full SUNWCall package was no longer installed on our Sol 10 build.

Cisco Employee

Re: LMS 3.1 CM 5.1.1: UT export error "native2ascii: not found"

An empty file would still cause breakage. At the very least, you'd need something like the attached.

Blue

Re: LMS 3.1 CM 5.1.1: UT export error "native2ascii: not found"

Thanks. If a blank one won't suffice, I might as well try to justify the bona fide native2ascii.

Cisco Employee

Re: LMS 3.1 CM 5.1.1: UT export error "native2ascii: not found"

I've filed a bug for this, CSCsw20310. Essentially, you need the JDK included with Solaris to be installed.

Blue

Re: LMS 3.1 CM 5.1.1: UT export error "native2ascii: not found"

The option currently on my table is to have SUNWj5de installed into an alternate location (outside of /usr/java/bin or /bin), and point LMS/RME's JAVA_HOME variable to that location. My chief concern with this approach is this would address the "native2ascii" issue but introduce a host of other "[binary] not found" problems. The SUNWCall package is very large, and it's by design that it's not fully installed.

Cisco Employee

Re: LMS 3.1 CM 5.1.1: UT export error "native2ascii: not found"

This would not work. The solution is to make sure a native2ascii is in the PATH. This is why the symlink or executable needs to be in /bin or /usr/bin. In a future release, it will be included in /opt/CSCOpx/campus/bin.

Blue

Re: LMS 3.1 CM 5.1.1: UT export error "native2ascii: not found"

Could casuser's PATH be modified to include /custom/location/native2ascii? That would seem the least painful solution, if possible.

Cisco Employee

Re: LMS 3.1 CM 5.1.1: UT export error "native2ascii: not found"

You would have to modify PATH in the pkgparam file for CSCOmd.

Blue

Re: LMS 3.1 CM 5.1.1: UT export error "native2ascii: not found"

Great! I'll give that a shot. Would dmgtd need to be restared to pick up the PATH change? Could this workaround potentially get overwritten by later LMS patches?

Cisco Employee

Re: LMS 3.1 CM 5.1.1: UT export error "native2ascii: not found"

Yes and yes.

Blue

Re: LMS 3.1 CM 5.1.1: UT export error "native2ascii: not found"

The PATH mod works great on my test box. Which release would come bundled with native2ascii, RME 4.3?

Cisco Employee

Re: LMS 3.1 CM 5.1.1: UT export error "native2ascii: not found"

The next Campus Manager IDU should have it (CM 5.0.5, 5.1.2) as well as LMS 3.2.

331
Views
17
Helpful
15
Replies
CreatePlease to create content