Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

LMS 3.1 - CV and RME 4.2

1. while clicking the Software summary in RME i get the following error.

HTTP Status 500 -

--------------------------------------------------------------------------------

type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

java.lang.NullPointerException

java.util.Hashtable.put(Hashtable.java:401)

com.cisco.nm.rmeng.inventory.reports.util.IRUtils.getDeviceDisplayNames(IRUtils.java:581)

com.cisco.nm.rmeng.inventory.reports.ui.action.InventoryReportsAction.perform(InventoryReportsAction.java:772)

org.apache.struts.action.ActionServlet.processActionPerform(ActionServlet.java:1786)

org.apache.struts.action.ActionServlet.process(ActionServlet.java:1585)

org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:509)

javax.servlet.http.HttpServlet.service(HttpServlet.java:709)

javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

com.cisco.nm.cmf.util.AccessLogFilter.doFilter(AccessLogFilter.java:100)

note The full stack trace of the root cause is available in the Apache Tomcat/5.5.17 logs.

--------------------------------------------------------------------------------

Apache Tomcat/5.5.17

2. In CV my 2960 switches ports are swapped. (fa0/3 shows conf for fa0/1). IOS is 12.2(25)FX

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: LMS 3.1 - CV and RME 4.2

No. The patch was for inventory collection. This problem is with reporting, and the contents of the RME database.

10 REPLIES
Cisco Employee

Re: LMS 3.1 - CV and RME 4.2

1. This points to a problem with your RME inventory. There is a device in RME which doesn't exist in DCR. The invreports.log will reveal the problem device, but you will need TAC's help to remove it from the database.

2. This is actually a conflict between the older version of switch code, and the new Cat2960 CiscoView package. The bug is CSCsj23639. Essentially, you need to upgrade the switch to 12.2(25)SEE3, 12.2(35)SE1, or 12.2(37)SE (or higher) to fix this problem.

Re: LMS 3.1 - CV and RME 4.2

1. Thanks. I will take it from here and will get back to u if i face anything more.

2. but the bug says "Cisco IOS software 12.2(25)FX is not affected by this problem". so i am not sure why u suggest upgrading.

Cisco Employee

Re: LMS 3.1 - CV and RME 4.2

The problem is a conflict between the package and the switch code. Essentially, the Cat2960 team changed the way the ENTITY-MIB behaved in newer versions of code (i.e. after 12.2(25)FX). So, the CiscoView developers updated the package code to handle this. Unfortunately, the two ENTITY-MIB schemes are incompatible. So, if you have 12.2(25)FX, you need to run an older version of the CiscoView Cat2960 package (which you can no longer do). Therefore, you must move forward in your switch code in order to catch up with CiscoView.

This problem has already been seen by two other customers, and an upgrade fixed them both.

Re: LMS 3.1 - CV and RME 4.2

1. one more thing. i recently patched for the bug CSCsx58694. By any chance can this be the source of the issue.

2. thanks this cleared my doubt.

Cisco Employee

Re: LMS 3.1 - CV and RME 4.2

No. The patch was for inventory collection. This problem is with reporting, and the contents of the RME database.

Re: LMS 3.1 - CV and RME 4.2

yeah, i get you.

Thanks for all the help.

Re: LMS 3.1 - CV and RME 4.2

1. if i add the concerned device(s) in the DCR once again. will it help.

Cisco Employee

Re: LMS 3.1 - CV and RME 4.2

No. The problem is that the DCR ID in the RME database no longer exists. DCR IDs always increment, and are never reused. Database surgery will be required. Alternatively, you can reinitialize the RME database, but that will cause you to lose all of the RME data you have collected thus far.

Re: LMS 3.1 - CV and RME 4.2

i see. thank you for your help.

Re: LMS 3.1 - CV and RME 4.2

I reinitialised the database. Manually imported the devices from DCR. I noticed that when the devices are less. it works fine. but as the number of devices grows, it seems to have a problem.

pl help.

158
Views
0
Helpful
10
Replies
CreatePlease login to create content