Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

LMS 3.1 Device Discovery issue

Hello,

I have been getting myself familiar with LMS, but can't figure out why I am having issues seeing some devices. I can't find any solution to my problem on other posts.

I have a server farm connected to my core switch, both can see each other via CDP, and the SF can ping the LMS server. However, I have 'device unreachable' on device discovery and CiscoView. SNMP community strings are the same on each device, and are configured on LMS.

Any suggestions? Thanks in advance!

8 REPLIES
New Member

Re: LMS 3.1 Device Discovery issue

Have you confirmed that the device you are attempting to manage is on the Supported Devices list?

http://www.cisco.com/en/US/docs/net_mgmt/ciscoworks_lan_management_solution/3.1/device_support/table/lms31sdt.html

New Member

Re: LMS 3.1 Device Discovery issue

Yes, it is on the list (Cat 4510R-E).

New Member

Re: LMS 3.1 Device Discovery issue

What I have done in the past is to run wireshark defining just the host IP that you are trying to gather information from.  Perform this at the LMS server and initiate the connection to the device.  Look for the SNMP connections and see if the connection is made.  I have found in the past that snmp from the LMS server was not allowed to some of the devices and I had to add the LMS server IP to the approved ACL for SNMP connections.

Silver

Re: LMS 3.1 Device Discovery issue

Hi,

LMS tries to contact each device directly via SNMP. If it can talk directly to the device, the device is added into DCR as Reachable. If it cannot talk directly to the device, the device is deemed as Unreachable and it is not added into DCR to be managed by LMS.

If LMS is unable to communicate it could be due to any number of things including timeout, incorrect community string, snmp-server view, firewall or access list.

A definitive way to determine the issue would be to perform a packet capture during discovery to see the SNMP transaction between LMS and an 'unreachable' device.

You can also try increasing the timeout value.

Thanks.

New Member

Re: LMS 3.1 Device Discovery issue

Thanks for your responses.

I ran a packet trace and the unreachable device was never once sent an SNMP packet.  Further, running the Device Troubleshooting Report on the CW Assistant shows that SNMP v2c read/write failed (my obvious problem), while other devices would pass. Everywhere else that I can think to check device settings for SNMPv2 read/write strings seem to be fine. Any thoughts? Thanks!

Silver

Re: LMS 3.1 Device Discovery issue

Hi,

If you have differing SNMP communities defined then have a look at your discovery settings. Specifically the SNMP strings.

CS > Device and Credentials > Device Discovery > Discovery Settings > SNMP Settings

Thanks.

New Member

Re: LMS 3.1 Device Discovery issue

I have verified the community strings, and have even changed them to plain alphanumeric in case it was a character issue. All other devices currently registered have the same SNMP strings, with no problem. Also tried SNMP walk tool inside LMS, which also fail.

Packet trace on the server gives me the following:

The device that LMS (172.20.103.60) fails to reach is the server farm switch (Cat 4510R-E) at 172.20.254.51 that it is directly connected to.

Thanks

Silver

Re: LMS 3.1 Device Discovery issue

Hi,

Have you verified that UDP port 161 is open on 172.20.254.51? Can any device snmpwalk the Cat 4510R-E or is it only LMS that is having trouble?

Thanks

470
Views
0
Helpful
8
Replies
CreatePlease login to create content