Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

LMS 3.1 win2k3 - Unable to update device credentials

Hi guys,

When trying to update device credentials on a LMS 3.1 win2k3 server with patches CSCsu84143-01 and cwa1.1.0-win-CSCsv592911 installed, I got the error on the message attached. Don't have this LMS integrated with ACS.

After enabling Device and Credentials Repository debug on Common Services > Server > Admin > CS Log Configurations and reproducing the problem, I got the error showed on dcr.log file.

Does anyone have an idea about what can be wrong? I've found the same problem here in forum, but couldn't find an answer to this problem.

Thank you,

Best Regards.

Flaviano.

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: LMS 3.1 win2k3 - Unable to update device credentials

Server 1 has the patch applied. I'm not sure what server 2 has.

6 REPLIES
Cisco Employee

Re: LMS 3.1 win2k3 - Unable to update device credentials

The error still points to CSCsu84143. It looks as though this patch was not properly applied. What is the MD5 checksum on NMSROOT/lib/classpath/com/cisco/nm/dcr/InternalDCR.class?

New Member

Re: LMS 3.1 win2k3 - Unable to update device credentials

Hi Joe,

Tks. How can I check MD5 of a file on windows? I've googled, but just found programs for download to do this! Is it necessary to install an additional software, or is there any native command, like in linux?

Thanks,

Regards,

Flaviano.

Cisco Employee

Re: LMS 3.1 win2k3 - Unable to update device credentials

Yes, you will need to download an external program to do this.

New Member

Re: LMS 3.1 win2k3 - Unable to update device credentials

Hi,

I've checked class files' md5. I've 2 server instaled, both with LMS 3.1 and both should have the same patches applied, but when checking MD5 of each file, I've 2 different values:

-> CWLMS server 1:

bd9c0c46e504a74dbf56c0d334108680

-> CWLMS server 2:

a35ad420336fb09496fd282e7b18c4fa

So, whith this md5 values it's possible to know what are the ciscoworks' patches installed? Or if CSCsu84143 is installed on both of then?

PS: I should have both CSCsu84143-01 and cwa1.1.0-win-CSCsv592911 patches on both server. Don't know if CSCsu84143 was not correctly installed in one of then!

Thank you very much.

Best REgards,

Flaviano,

Cisco Employee

Re: LMS 3.1 win2k3 - Unable to update device credentials

Server 1 has the patch applied. I'm not sure what server 2 has.

New Member

Re: LMS 3.1 win2k3 - Unable to update device credentials

After applying the patch the MD5 is correct now. Don't know if the patch was not applied by customer or if some error had occurred when applying it. Now the problem should be fixed!

Thank again for your help Joe.

Regards,

Flaviano.

252
Views
5
Helpful
6
Replies
CreatePlease to create content