Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

LMS 3.2 DFM Import of Devices Failed

Hi,

My name is Ashley. I have recently installed LMS 3.2. Everything is working fine, CM, CS,HUM, RME,IPM. However, I am not able to import devices from DCR to DFM.

On Auto Allocation Window, I get the following error:

Error in getting instance of TreeGenerator class 
com.cisco.nm.trx.kdm.utils.DcrGroupSelectorTreeGenerator
Root Cause:com.cisco.nm.xms.ctm.common.CTMException: URN_NOT_FOUND : urn "ogs_server_urn" : Not found !!

On Manual Allocation, I cannot see any device in the DCR.

I have seen in a post how to reset the DFM database, but still does not work.

net stop crmdmgtd

cd CSCOpx\bin
del NMSROOT/objects/smarts/local/repos/icf/DFM.rps


del NMSROOT/objects/smarts/local/repos/icf/DFM1.rps

perl dbRestoreOrig.pl dsn=dfmEpm dmprefix=EPM

perl dbRestoreOrig.pl dsn=dfmInv dmprefix=INV

perl dbRestoreOrig.pl dsn=dfmFh dmprefix=FH

net start crmdmgtd
perl dbaccess.pl install

Could you please help, I am running out of ideas.

Everyone's tags (2)
7 REPLIES
Cisco Employee

Re: LMS 3.2 DFM Import of Devices Failed

Post the output of the pdshow command from this server.

New Member

Re: LMS 3.2 DFM Import of Devices Failed

Please find the pdshow output

Cisco Employee

Re: LMS 3.2 DFM Import of Devices Failed

Post the output of the command:

NMSROOT/objects/smarts/bin/brcontrol
New Member

Re: LMS 3.2 DFM Import of Devices Failed

Please find the requested output.

Cisco Employee

Re: LMS 3.2 DFM Import of Devices Failed

It looks like you might be hitting a known bug.  Try rebooting the server, then see if this problem goes away,

New Member

Re: LMS 3.2 DFM Import of Devices Failed

Hi Joe,

The problem persists when rebooting. I have tried on several occasions.

Is there a patch for that bug available.

Cisco Employee

Re: LMS 3.2 DFM Import of Devices Failed

If the problem persists after a full server reboot, then you are probably not seeing this bug.  Post the NMSROOT/objects/smarts/local/logs/DFM.log and DFM1.log as well as the brcontrol output after the full reboot.

549
Views
0
Helpful
7
Replies