Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

LMS 3.2 discovery process runs for ever

Dear friends,

I am having a problem with discovery on Ciscoworks LMS 3.2. The discovery process runs eternally and does not discover any devices.


Here are the individual device versions:

Name   Version   Size   Status   Expiration Date 
1. CM 5.2 300 Purchased Never
2. DFM 3.2 300 Purchased Never
3. HUM 1.0 100 Evaluation Sun Jul 26 12:18:01 GMT+03:00 2009
4. IPM 4.2 300 Purchased Never
5. RME 4.3 300 Purchased Never
6. VNM 1.0 Unlimited Purchased Never


Please find enclosed the csdiscovery.log which indicates the following error

1000 [main] DEBUG com.cisco.nm.csdiscovery.CSDiscoveryManager  - FATAL: Exception occured in the start discovery Exception occured during start of discovery in CS.
Reason : failed to initialize DiscoveryController


I am also enclosing the CSDiscovery-config.xml under the config directory and the specific job as well.

ngdiscovery.log shows 0 bytes. I am not sure if it is to be populated only when we initiate some debugging?

Thanks a lot
Gautam

5 REPLIES
Cisco Employee

Re: LMS 3.2 discovery process runs for ever

It seems you're missing some critical files.  Under NMSROOT/conf/csdiscovery, you should have the following zip files:

SharedDiscoveryAUS.zip

SharedDiscoveryCluster.zip

SharedDiscoveryGeneral.zip

SharedDiscoveryIGX.zip

The casusers group should have full control on all four files.  If these files really are missing, you will need to contact TAC to get new ones, or you will need to reinstall Common Services.

New Member

Re: LMS 3.2 discovery process runs for ever

Dear Jason,

I do have all the four files and the casusers does have full control over these four files under C:\Program Files (x86)\CSCOpx\conf\csdiscovery directory.

Thanks a lot

Gautam

Cisco Employee

Re: LMS 3.2 discovery process runs for ever

Try replacing your CSDiscovery-config.xml with this version.  Also, delete all Discovery jobs you may have scheduled, and reschedule them after replacing the file, and testing that an ad hoc discovery works.

New Member

Re: LMS 3.2 discovery process runs for ever

Dear Jason,

I have started the discovery now and it seems to be running as before.

But when i click on Start discovery button in Discovery settings, it should change to Stop Discovery, right?

But it does not change to Stop Discovery.

I still seem to see the same symptoms.

Thanks a lot

Gautam

New Member

Re: LMS 3.2 discovery process runs for ever

Jason,

I am also closing this thread with the same resolution: reinstall fixed everything!!

Thanks a lot

Gautam

706
Views
0
Helpful
5
Replies