Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

LMS 3.2 integration with ACS 5.1

Hi

Is it possible to integrate LMS 3.2 with ACS 5.1? I know it works with ACS 4.X, but I can't get it to work with ACS 5.1.

Here is a link to how to do it with ACS 4.X:

http://www.cisco.com/en/US/prod/collateral/netmgtsw/ps6504/ps6528/ps2425/prod_white_paper0900aecd80613f62.html

Regards

Reidar

2 ACCEPTED SOLUTIONS

Accepted Solutions

Re: LMS 3.2 integration with ACS 5.1

according to this thread, it seems ACS 5.1 is ready for LMS integration but LMS is not readdy for ACS 5.1 integration ....

https://supportforums.cisco.com/message/675371#675371

Cisco Employee

Re: LMS 3.2 integration with ACS 5.1

LMS cannot and will not be able to integrate with ACS 5.x.  The reason for this is that ACS 5.x removed the necessary integration hooks.  The plan for LMS going forward is to remove ACS integration support, and add support for customizing roles into LMS directly.  ACS will still be supported for authentication, though (this includes ACS 5.x).  ACS 5.x is supported for integration ONLY today in LMS 3.2.

12 REPLIES

Re: LMS 3.2 integration with ACS 5.1

according to this thread, it seems ACS 5.1 is ready for LMS integration but LMS is not readdy for ACS 5.1 integration ....

https://supportforums.cisco.com/message/675371#675371

New Member

Re: LMS 3.2 integration with ACS 5.1

Thank you. Then I'm going to use the ACS as an TACACS+ until LMS will support ACS 5.X

Re: LMS 3.2 integration with ACS 5.1

there is still one think I am curious about... jclarke talked about summer 2010, this is the expeted release date for LMS 4.0 - so I am not sure if was thinking of LMS 3.2  or LMS 4.0 (or both) when he talked abut support for ACS 5.1....

New Member

Re: LMS 3.2 integration with ACS 5.1

Guys i seem to be having the same issue, has this been resolved? This is Mid-may.

Regards

New Member

Re: LMS 3.2 integration with ACS 5.1

None that I'm aware of. It seems that there is a bug in ACS 5.1 as well. When I configure the LMS server to use TACACS+ the ACS server will give the user level 1 access, even if I have configured the ACS server to grant level 15 access. It could also be that I have configured the ACS server wrong :-)


/Reidar

New Member

Re: LMS 3.2 integration with ACS 5.1

Thanks Reidar.... hmm very strange. I really wish an expert would respond to this thread as it will help a lot of people who might be planning to deploy these versions and they can help put this matter to rest once and for all. Not sure why LMS 3.2 will not support ACS 5.1 and it might help to know when it will (updates etc). Kindly let me know if you get any further information. My deployment is so large that setting a local username and password on all the devices is not an option unfortunately .......

Cisco Employee

Re: LMS 3.2 integration with ACS 5.1

LMS cannot and will not be able to integrate with ACS 5.x.  The reason for this is that ACS 5.x removed the necessary integration hooks.  The plan for LMS going forward is to remove ACS integration support, and add support for customizing roles into LMS directly.  ACS will still be supported for authentication, though (this includes ACS 5.x).  ACS 5.x is supported for integration ONLY today in LMS 3.2.

New Member

Re: LMS 3.2 integration with ACS 5.1

You wrote:

...

The plan for LMS going forward is to remove ACS integration support, and add support for customizing roles into LMS directly

...

That sound very, very good !!!  Will this function already be implemented in LMS 4.0 ?

Best Regards

Hendrik

Cisco Employee

Re: LMS 3.2 integration with ACS 5.1

Yes, LMS 4.0 will have locally customizable user roles.

New Member

Re: LMS 3.2 integration with ACS 5.1

Joe, i think i'm having issues even with the authentication. The error i'm getting is protocol mismatch have you seen this before?

Regards

Cisco Employee

Re: LMS 3.2 integration with ACS 5.1

Start a new thread for this problem.

New Member

Re: LMS 3.2 integration with ACS 5.1

Sure Joe will do.

856
Views
0
Helpful
12
Replies
CreatePlease to create content