Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

LMS 3.2 - Issue with RME

Heloo,

I found that ConfigMgmtServer process status is "Program started but no msgs received". We are seeing some issues like devices partially fetching the configuration. Is that due to this process status issue...??

Even i restarted that particular process. What can be done to make status "Running Normally"...?

Thanks in advance..

7 REPLIES
Cisco Employee

LMS 3.2 - Issue with RME

This is also a healthy state of some processes. So the issue is not with the process. If that is no in this state or running, it may not let RME to collect config archive.

Partially successful devices are usually because of vlan.dat file. RME does config archive in two steps:

1.  Collect config (startup/Running)

2.  Collect VLAN.dat file

Second steps needs TFTP to work properly and due to some reason, like:

> Telnet/SSH credentials not correct

> TFTP is blocked by FW/any policy

> timeout needs to be increased

> Device not supported

You should share the debug dcma.log file with fresh sync job (remove old content form dcma.log) and also share screenshot of the error of job result.

-Thanks Vinod **Rating Encourages contributors, and its really free. **
New Member

LMS 3.2 - Issue with RME

Thanks a lot for your reply Mr. Vinod...

I have cleared the dcmaservice.log file and created the sync archive job.

But i am not getting any logs in NMSROOT\log\dcmaservice.log . after that.

And i could see one more file dcmaclient.log file. what is the difference between that..?

Archive settings path i have set properly. Any clue.


Cisco Employee

LMS 3.2 - Issue with RME

What is the status of the job?

-Thanks Vinod **Rating Encourages contributors, and its really free. **
New Member

LMS 3.2 - Issue with RME

Partially successful with the below error

Insufficient no. of interactive responses(or timeout) for command: copy const_nvram:vlan.dat tftp:.TELNET: Failed to establish TELNET connection to x.x.x.x - Cause: Connection refused. VLAN Config fetch is not supported using TFTP. VLAN Config fetch is not supported using SCP.

New Member

LMS 3.2 - Issue with RME

Hi Frndz,

Any suggestion here ....

Cisco Employee

LMS 3.2 - Issue with RME

As per my above response the error is similar to point#1, SSH/Telnet incorrect credentials :

TELNET: Failed to establish TELNET connection to x.x.x.x - Cause: Connection refused.

Please run a device credential report from RME > Device management > CDA and share if telnet/ssh is correct. If device is configured for telnet and you can correct credentials in LMS and device is configured for AAA auth, than you'll have to configure tacacsprompt.ini.

Usually it is essential to configure the $NMSROOT\objects\cmf\data\TacacsPrompts.ini file. As with tacacs+ Auth you can also define custom login username and password prompt, hence this file is important to be configured, only in case of Telnet not SSH.

So just check the login prompt you get in your device when you try to do telnet and mention the same in you

TacacsPrompts.ini file.

Example:

>Following is the content of TacacsPrompts.ini :

[TELNET]

USERNAME_PROMPT=

PASSWORD_PROMPT=

> Following is the username and pasword propmt for my device :

> As per this please modify the file as :

[TELNET]

USERNAME_PROMPT=Username:

PASSWORD_PROMPT=Password:

Just save and try to run the job again for failing device.

-Thanks Vinod **Rating Encourages contributors, and its really free. **
New Member

LMS 3.2 - Issue with RME

Thanks for your reply. Now its likely to be passing the sync archive but if we see it in the 'Device Center' it shows the last date. Recent date is not shown but it fetches the config properly.

And also how to automatic the config fetch for group of devices...?

214
Views
0
Helpful
7
Replies