Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

LMS 3.2 on windows installation hangs

I've tried a couple of times now to install the latest 3.2 evaluation on our test system.

I start the lms-3-2-Win-eval.exe and assume if there was an issue with this file the unpack will complain?

The server has the US locale and meets the specs and LMS 3.1 was running fine.

No errors are written to the installation log, even when I kill the hanging process.

setting property REBOOT=ON into property List ..., adding property done

setting property RUN_DMGR=ON into property List ..., adding property done

setting property ABORT=OFF into property List ..., adding property done

HOOK: tomcat_POSTINSTALL 12:30:47 ,Tue 08/11/2009 ,Romance Standard Time

getting property NAME from property list ..., found: TomCat

getting property NAME from C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\{1D01B~1\{11B83~1\setup\tomcat.info..., done

MultiScript END POSTINSTALL: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\{BA1D3~1\cdone_a.inx at 14:16:48 ,Tue 08/11/2009 ,Romance Standard Time

DEBUG: cleaning lMultiPkg

As you can see the sever was hanging between 12:30 and 14:16 when I killed an idle setup process.

The installation now continues and finishes but there always seems to be something not right. Different issues every time so far.

Can I run the lms-3-2-Win-eval.exe with the same command line options as the setup? Or can I somehow extract the contents?

Cheers,

Michel

11 REPLIES
New Member

Re: LMS 3.2 on windows installation hangs

Just adding the install log.

No errors.

Cheers,

Michel

Cisco Employee

Re: LMS 3.2 on windows installation hangs

I typically recommend one to do the following to ensure a proper installation on Windows:

* Set the TEMP and TMP environment variables to something short like C:\WINDOWS\TEMP.

* Disable anti-virus scanning.

* Disable Data Execution Prevention (DEP).

* Install as local Administrator.

* Install on the server's console.

It looks like you're already installing as local Administrator, but the TEMP and TMP paths are the default.

Also, if you are running the installer from within the zip file, don't. Extract the .exe, then run it directly.

New Member

Re: LMS 3.2 on windows installation hangs

I will shorten temp and tmp to d:\t

There is no antivirus, DEP is off

I'm local administrator on the console of the VM

I would like to extract the exe.

I tried winzip but it doesn't like the exe archive.

How do I do this extract?

Cheers,

Michel

Cisco Employee

Re: LMS 3.2 on windows installation hangs

If you executing the .exe directly, that is fine. What we saw in the past was the .exe was shipped within a .zip. People would run the .exe from the .zip rather than first extracting it, then double-clicking on the extracting .exe.

What version of VMWare are you using?

New Member

Re: LMS 3.2 on windows installation hangs

I've adjusted the temp and tmp var to d:\t

VMware Infrastructure Web AccessVersion 2.0.0Build 122589

VMware ServerVersion 2.0.0Build 122956

Lets see if it gets beyond the tomcat configuration this time.

Thanks for your help so far Joe.

Cheers,

Michel

Cisco Employee

Re: LMS 3.2 on windows installation hangs

Your problem may be related to the fact you're using an unsupported version of VMWare. We only support VMWare ESX 3.x with LMS.

New Member

Re: LMS 3.2 on windows installation hangs

The install now goes to the end. The "hanging" problem is fixed.

I set the temp and tmp to d:\t and used vnc rather then vmware console to check every once in a while how the install was going.

Ciscoworks still doesn't work. Quite a few services have "Never Started" state.

I will run uninstall once more now the install works properly again.

I appreciate that I should use ESX but that hardware will become available in the future somewhere. And sice this is not a production environment instability is not a issue

And I really hope Ciscoworks doesn't notice its on a (unsupported) VM ;-) . That's the point of a VM.

You mention a clean_system.exe. Does it change with the version of LMS? Iow do I need a 3.2 version to delete LMS 3.2?

Thanks,

Michel

Cisco Employee

Re: LMS 3.2 on windows installation hangs

TAC will notice. Additionally, the problems you're experiencing could be related to the untested VM environment. I just want to brace you for problems. You may be fine, but since you're in uncharted waters, I cannot say for certain what you may encounter.

New Member

Re: LMS 3.2 on windows installation hangs

Thanks Joe,

Problems on this box don't go to the TAC. But I do tend mention if I can recreate the customers problem on this server. And I tend to test the fix received from the tac as well. Better to break things in the lab then out there

You already replied to my previous message when I added my last question in there.

Does the clean_system utility change with the different versions of LMS? Do I need a recent one of LMS 3.2?

Cheers,

Michel

Cisco Employee

Re: LMS 3.2 on windows installation hangs

It doesn't change with releases per se. There are two versions. One is for LMS 2.x. It is called clean_system.exe. A new version was made when LMS 3.0 was released. It may be called clean_system1.exe, but it could easily have been renamed clean_system.exe. The difference is the new version knows how to clean up OpsXML registry entries for CiscoWorks Assistant where as the old one did not.

New Member

Re: LMS 3.2 on windows installation hangs

Thanks Joe,

I'll get myself a new one then.

Cheers,

Michel

409
Views
10
Helpful
11
Replies