Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

LMS 3.2 Portal Problem

When I try to access the Portal I get the login screen

and enter my username and password

and when I hit enter I get the following screen.

Forbidden

You don't have permission to access /cwhp/LiaisonServlet on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

This is both remotely as well as on the server itself.  Can anybody point me in the right direction?

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: LMS 3.2 Portal Problem

Tomcat is taking too long to startup.  Is LMS installed on locally attached drives, or on a SAN?  What are the hardware specs of this server?  Try disabling anti-virus, and any other non-Windows, non-LMS services, then reboot, and see if LMS comes up then.

13 REPLIES
Cisco Employee

Re: LMS 3.2 Portal Problem

Post the output of the pdshow command from the server as well as screenshots of your Services control panel showing all of the CiscoWorks services.

New Member

Re: LMS 3.2 Portal Problem

I finaly saw the earlier post and reset the services to their original settings and rebooted the server but the CW Tomcat Servlet and the CW Web Server services never start.  So now I get a " page cannot be displayed" error when I try to connect.  I tried starting those two services and then accessing and got the "Forbidden" message again.

Cisco Employee

Re: LMS 3.2 Portal Problem

Post the NMSROOT/MDC/tomcat/logs/stdout.log and stderr.log.

New Member

Re: LMS 3.2 Portal Problem

Here they are

Cisco Employee

Re: LMS 3.2 Portal Problem

I still think your services are wrong.  Post the screenshot I asked for previously.

New Member

Re: LMS 3.2 Portal Problem

Here is the screen shot

Cisco Employee

Re: LMS 3.2 Portal Problem

Set the Daemon Manager service to Manual, then reboot.  When the server comes back up, collect the output of the command "netstat -a -n -o -b", and post the NMSROOT/MDC/etc/regdaemon.xml, NMSROOT/lib/classpath/md.properties, and NMSROOT/MDC/Apache/logs/error.log files.

New Member

Re: LMS 3.2 Portal Problem

Here you go

Cisco Employee

Re: LMS 3.2 Portal Problem

Okay, now set the Daemon Manager service back to Automatic, then run:

net start crmdmgtd

Wait about 30 minutes, then collect the output of the following command:

pdreg -l Apache
New Member

Re: LMS 3.2 Portal Problem

Here is the output you requested.

C:\>pdreg -l Apache

        Process      = Apache

        Path         = D:\PROGRA~1\CSCOpx\MDC\Apache\bin\Apache.exe

        Flags        = -d D:\PROGRA~1\CSCOpx\MDC\Apache -D SSL

        Startup      = Started automatically at boot.

        Dependencies = TomcatMonitor

Cisco Employee

Re: LMS 3.2 Portal Problem

This checks.  Hopefully you haven't manually started any services other than Daemon Manager.  If so, are you seeing the same problem (i.e. "page cannot be displayed")?  If so, post the new stdout.log and stderr.log (do NOT try starting Tomcat manually).  Also, look for any hs_err* files on the file system.  Post any you find.

New Member

Re: LMS 3.2 Portal Problem

Yes I am seeing the same problem (i.e. "page cannot be displayed").  Attaced are the files you requested, I could find any hs_err* files.

Cisco Employee

Re: LMS 3.2 Portal Problem

Tomcat is taking too long to startup.  Is LMS installed on locally attached drives, or on a SAN?  What are the hardware specs of this server?  Try disabling anti-virus, and any other non-Windows, non-LMS services, then reboot, and see if LMS comes up then.

1327
Views
0
Helpful
13
Replies
CreatePlease to create content