Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

LMS 3.2 - Problems with Apache

Hi all,

I have a LMS3.1 installed in a Windows server and, since I installed it, I've faced some problems regarding to Apache. I attached the error message that I often received from LMS.

Do you have any clue about my issue?

Best Regards,

Rodrigo Vieira

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: LMS 3.2 - Problems with Apache

I think the problem is related. The servlet failing directly interacts with the login module. This is why I suggested trying the local authentication module for a while to see if the problem goes away.

9 REPLIES
Cisco Employee

Re: LMS 3.2 - Problems with Apache

Is this LMS 3.2 or 3.1? Post the NMSROOT/MDC/tomcat/logs/stdout.log and stderr.log.

Community Member

Re: LMS 3.2 - Problems with Apache

Hi Joe,

We are using LMS3.1! I posted the log files that you've asked me!

Best Regards,

Rodrigo Vieira

Cisco Employee

Re: LMS 3.2 - Problems with Apache

I'm not seeing any obvious errors here. When did this problem last occur?

Community Member

Re: LMS 3.2 - Problems with Apache

Hi joe,

I got this error today morning (~11:00am - GMT -2).

I checked those logs and I didn't see anything wrong too.

I am not sure if we had a instalation problem here, but do you think it would be a good idea reinstall LMS again? Perhaps we should install the new version, LMS 3.2.

Cisco Employee

Re: LMS 3.2 - Problems with Apache

Hmmm, I think there is a problem with your LDAP module config:

[--- LDAPModule ---] calling doLoing with userprovided credentials..

[--- LDAPModule ---] In the overloaded method of thje getDN

[--- LDAPModule ---] Search filter is [(&(sAMAccountName=admin))]

[--- LDAPModule ---] Unable to get [sAMAccountNam] with just username, so constructing default DN..

[--- LDAPModule ---] the SECURITY_PRINCIPLE is now [sAMAccountName=admin,ou=cpd,dc=ad,dc=ufrgs,dc=br]

[--- LDAPModule ---] The bindDN [sAMAccountName=admin,ou=cpd,dc=ad,dc=ufrgs,dc=br] will be used as Context.SECURITY_PRINCIPAL

[--- LDAPModule ---] Exception when binding toldap://kquatro.ad.ufrgs.br: [LDAP: error code 49 - 80090308: LdapErr: DSID-0C09030B, comment: AcceptSecurityContext error, data 525, v893

Community Member

Re: LMS 3.2 - Problems with Apache

You are right, we have smoe problems with our LDAP, but do you think it could be linked with our problem?

It has been ocurring since we install it, and when it happens, we need to restart the server in order to access the LMS again (dmgtd doesn't work :().

Cisco Employee

Re: LMS 3.2 - Problems with Apache

I think the problem is related. The servlet failing directly interacts with the login module. This is why I suggested trying the local authentication module for a while to see if the problem goes away.

Community Member

Re: LMS 3.2 - Problems with Apache

Interesting! I have to take an authrization with our security team to modify the LMS authentication method and after it, I get back to you.

Community Member

Re: LMS 3.2 - Problems with Apache

Hi Joe,

Thank you for your tip! Now it's working fine. Unfortunatelly I've got another problem...I'll have to investiate our LDAP server. :(

Best Regards,

Rodrigo Vieira

421
Views
0
Helpful
9
Replies
CreatePlease to create content